Console error after click on link in Edge

Issue #19407264 • Assigned to Arvind M.

Details

Author
Svyatoslav Y.
Created
Oct 25, 2018
Privacy
This issue is public.
Found in
  • Microsoft Edge
Reports
Reported by 5 people

Sign in to watch or report this issue.

Steps to reproduce

Steps to reproduce:

  1. In Edge: Settings -> View Advanced settings ->Autofill settings -> turn on the Save form entries toggle switch
  2. page must contain: form with input, link with attribute target="_blank"
    For example:
<a target="_blank" href="https://www.microsoft.com/"> microsoft </a>
<form><input type="text"/></form>
  1. open/toggle developer tools
  2. click on input
  3. click on link
  4. pay attention on console
    SCRIPT5009: ‘getReferrerPolicy_’ is not defined in Autoformfill_ContentScript.js

The link was opened in a new tab, but the error is displayed in the console.

Microsoft Edge 42.17134.1.0
Microsoft EdgeHTML 17.17134

Attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Veerabhadra r.”

  • Hi, thank you for reporting your feedback. We tested it. and we were not able to reproduce with latest build. Please let us know, if you are having same issue with latest build.

    Latest build details:

    Microsoft Edge 44.17763.1.0
    Microsoft EdgeHTML 18.17763

    Thanks
    The MS Edge Team.

  • Can you confirm it’s reproducible and expected on MS Edge 42.* version?

    I need to know whether it’s known issue of Edge or the bug in my webservice.

  • Veerabhadra, can you confirm this issue is reproducible and expected on MS Edge 42.* version?

    Is Microsoft Edge 44 officially released?
    Windows says my Edge is up to date, but it’s version is 42, not 44.

    In wikipedia (sorry, MS site is not very user-friendly to find the information like this) the latest Edge version is 42 also: https://en.wikipedia.org/wiki/Microsoft_Edge#Release_history

  • hey @Veerabhadra , any information about that?

  • Hello, We have performed additional testing using:
    Microsoft Edge 42.17134.1.0
    Microsoft EdgeHTML 17.17134
    With the following code loading from the desktop with all extensions disabled and Autofill settings -> turn on the Save form entries.

    <!DOCTYPE html>

    <html>​
       <head></head>​
       <body>​
         <a target="_blank" href="https://www.microsoft.com/"> Microsoft </a>​
         <form><input type="text"/></form>​
      </body>​
    </html>

    We are still having difficulties reproducing the issue using the same build version that you are using. To help us investigate further can you please confirm the issue happens with all extensions disabled, attach the code sample you are using or confirm our sample above reproduces the issue. 

    Microsoft Edge 44 is part of the Windows 10 October 2018 update. 

    Best regards,

  • Yes. All extensions are disabled. This sample reproduced the issue.
    I cannot reproduce this issue if i press Ctrl when i click a link

  • Microsoft Edge Team

    Changed Assigned To to “Arvind M.”

  • Getting the same error alot, but does not repro with the sample above.
    Also, getting occasional SCRIPT16389 Unspecified error from polyfill of the same package.

    Sadly, I am unable to repro it reliably all the time to help to solve it.
    Edge 42.17134.1.0

  • Correction: I do can also repro with the sample above.

  • I’m getting a similar error in an application we’re developing:
    Unable to get property 'isPersonal' of undefined or null reference

    It’s also coming from Autoformfill_ContentScript.js. Interestingly enough this error is not coming up in Edge version 42.17134.1.0 but is coming up in 44.17763.1.0.

    The error is caused by __gMsEdge.common.currentForm being null/undefined so it appears that whatever this file is trying to do with the form it’s failing at it by not finding it. I’m not seeing anything special or strange in the form to cause this.

  • Oh and that error is happening when entering data into a text input field on an AngularJs form. When entering data in a non-angular area of our site this error doesn’t come up.

  • I get the same error as David C. with a simple test page - as soon as I enter a letter in the input field:
    0: Unable to get property ‘isPersonal’ of undefined or null reference
    Autoformfill_ContentScript.js (1,168)

    TestScript.htm:

    
    
    
    
    
    
    
    
    
    
    
    
    
    
    

    Edge version:
    Microsoft Edge 44.17763.1.0
    Microsoft EdgeHTML 18.17763

    Can this bug be fixed?

  • Script without “Markdown” formatting:

  • <!DOCTYPE html>
    <html lang="en">
    <head>
    </head>
    <body>
    <form id="productForm" method="POST" autocomplete="off" action="dummy">
    <input name="formName" type="text" size="8" autocomplete="off" value=""/>
    </form>
    </body>
    </html>

  • We’ve also been running into this bug on the sign-in form on https://www.befunky.com/ in Edge 18.17763
    0: Unable to get property 'isPersonal' of undefined or null referenceAutoformfill_ContentScript.js (1,168)

  • I’ve run into this.
    latest version of an @angular/cli site with material.angular.io controls and all pollyfills.ts ‘import’ lines uncommented.

    In Edge’s settings section, Passwords & autofill
    If I turn off Autofill -> Save form data; the errors stop happening.

    Edge 44.17763.1.0
    EdgeHTML 18.17763

    If more information is needed, I’d be happy to help!

You need to sign in to your Microsoft account to add a comment.

Sign in