Edge doesn't clear input value on page reload

Not reproducible Issue #21174802

Details

Author
Артём Н.
Created
Apr 12, 2019
Privacy
This issue is public.
Found in
  • Microsoft Edge
  • Internet Explorer
Found in build #
17.17134
Reports
Reported by 2 people

Sign in to watch or report this issue.

Steps to reproduce

Hi! I’m developing webpage form via ReactJS+material-ui framework. I’m experiencing problem with autocomplete field (basically, input with list popover). The problem as follows: after the value has been chosen, I reload the page and the value stays on, but not really as variable in model, rather as some kind of render glitch (looks like placeholder, because when I focus input field, the text is gone). I’m attaching video of the process (autocomplete.flv). The problem doesn’t arise in other browsers. I don’t use cookies or local storage or any other mean of preserving the value.

Also, I experience quit similar problem with other input fields, only this time the value stays on for 2-3 seconds after page reload and then is erased. Attached video input.flv.

These are Edge version numbers: 42.17134.1.0, Microsoft EdgeHTML 17.17134
(I’m also attaching screenshot, but it’s in russian)

Thanks in advance!

Attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Zachariah L.”

  • Hi Артём!

    Thank you for contacting us about this issue! The most recent version of Microsoft Edge is Microsoft Edge 44.17763.1.0 Microsoft EdgeHTML 18.17763. Could you update your browser to the most recent version and see if the issue is still present?

    Thanks,
    Zach

  • Hi Артём!

    For now, I will resolve this issue as "Not Reproducible". If you are still experiencing this problem then please feel free to reopen this issue with the information requested and I will resume my investigation.

    Thanks,
    Zach

  • Microsoft Edge Team

    Changed Status to “Not reproducible”

  • Changed Status from “Not reproducible”

  • Hello! Sorry, took long but we’ve managed to update Edge to the latest. Unfortunately the problem is still present

  • Microsoft Edge Team

    Changed Assigned To to “Zachariah L.”

  • Hi Артём!

    Thanks for getting back to me! I will work on creating a reproduction of this issue locally but if you could provide a link to the page then that will help speed up my investigation.

    Thanks,
    Zach

  • Hi, Zachariah!
    Can I send you a link in some private message? Don’t really want to publish a production link

  • Hi Артём!

    Sure! You can email me at v-zaleon@microsoft.com.

    Thanks,
    Zach

  • Hi Артём!

    For now, I will resolve this issue as "Not Reproducible". If you are still experiencing this problem then please feel free to email me and reopen this issue.

    Thanks,
    Zach

  • Microsoft Edge Team

    Changed Status to “Not reproducible”

You need to sign in to your Microsoft account to add a comment.

Sign in