MS Edge Web Push Notification returns 406 Status Code

Issue #21871672 • Assigned to Arvind M.

Details

Author
ozgur h.
Created
May 30, 2019
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
17.17134
Reports
Reported by 8 people

Sign in to watch or report this issue.

Steps to reproduce

Hello,

We are a push provider company and we get 406 error code from MS Edge WebPush Endpoints. Almost every endpoint gives the same error.

We noticed that we get different subdomains for endpoints. And We only have problem for db5p.notify.windows.com and bl2p.notify.windows.com sub domains. We can send to sg2p.notify.windows.com and dm3p.notify.windows.com sub domains successfully. But the problem is we only get db5p subdomain for edge endpoints for these days.

To reproduce the error please go to webpushdemo.azurewebsites.net and try to send sample web push notification. If your endpoint has db5p or bl2p subdomains, you’ll see 406 Status Code as well.

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Zachariah L.”

      Changed Assigned To to “Arvind M.”

    • Seeing this as well, same situation - we’re a sending push on behalf of others and running into this issue. Is there a timeline for a fix or a workaround?

    • Same situation with the same error. We’re also interested in a timeline for a fix or workaround. Thanks!

    • Same situation with the same error. Tested also with onesignal, only notifications via edge didn’t work.

    • I’m getting the same thing, no response body but the following headers:

      {
              'Content-Length': '0',
              'X-WNS-NOTIFICATIONSTATUS': 'appthrottled',
              'X-WNS-STATUS': 'appthrottled',
              'X-WNS-MSG-ID': '4768E4C66ED12307',
              'X-WNS-DEBUG-TRACE': 'DB5PEPF00000450',
              'MS-CV': 'X24q7dAxCEWDaszJ5v2IAw.0',
              'Strict-Transport-Security': 'max-age=31536000; includeSubDomains',
              'Date': 'Thu, 13 Jun 2019 16:12:49 GMT',
          }
      

      The 406 response indicates this is a problem with the Accept header, but the header above indicate it’s something to do with throttling/

      An update would be great even if it’s "we’re looking into this".

    You need to sign in to your Microsoft account to add a comment.

    Sign in