Run WebDriver for Edge on Windows Server (2019)?

Site Outreach Issue #21968647

Details

Author
Marcelo D.
Created
Jun 4, 2019
Privacy
This issue is public.
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Is it possible to run the Edge WebDriver on Windows Server 2019 (or any non-Windows 10 OS)? https://developer.microsoft.com/en-us/microsoft-edge/tools/webdriver/ leads me to believe it isn’t, but I don’t want to give up prematurely.

Thanks!
Marcelo

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Zachariah L.”

    • Hi Marcelo!

      Thank you for contacting us about this issue! What version of Windows Server 2019 did you try this on?

      Thanks,
      Zach

    • Hi Zachariah:
      I tried to run the Edge WebDriver with Windows Server 2016 (https://developer.microsoft.com/en-us/microsoft-edge/platform/issues/19369514/)

      I want to know if it is possible to run the Edge WebDriver on Windows Server 2019 (any version)

      Thanks!
      Marcelo

    • Hi Marcelo!

      I haven’t been able to find any documentation stating anything specific. The quickest way to find out would be to just try it if you have access to a system running Windows Server 2019. I’m guessing this is not the case so I can try it myself and let you know. This may take longer than I would like because I have been having issues getting OS images recently. 

      Thanks,
      Zach

    • Hi Marcelo!

      After some research, the current Microsoft Edge is not available on Windows Server due to how Microsoft Edge is updated with Windows Updates. So instead, I tested the new Microsoft Edge Canary and that ran on Windows Server 2019. I also downloaded its respective webdriver and that seems to function as well. I didn’t
      test this thoroughly but the VM didn’t complain. 

      Microsoft Edge Canary: https://www.microsoftedgeinsider.com/en-us/download

      Microsoft Edge Canary Webdriver: https://developer.microsoft.com/en-us/microsoft-edge/tools/webdriver/

      Configuring selenium to use chrome bindings to automate Canary: https://pastebin.com/2UjM2ux9

      For now, I will resolve this issue as "External". If you need any additional help then please feel free to reopen this issue.

      Thanks,
      Zach

    • Microsoft Edge Team

      Changed Status to “Site Outreach”

    You need to sign in to your Microsoft account to add a comment.

    Sign in