ajax request hangs when referring to server by IP address and WindowsAuthentication is enabled in IE11

Not reproducible Issue #2222759

Details

Created
Mar 31, 2015
Privacy
This issue is public.
Reports
Reported by 0 people

Sign in to watch or report this issue.

Steps to reproduce

URL:

Repro Steps:

  • Allow configuring WindowsAuthentication and AnonymousAuthentication via the C:\Windows\System32\inetsrv\config\applicationHost.config file;
  • Enable WindowsAuthentication and disable AnonymousAuthentication in the site’s Web.config file:

<?xml version="1.0"?>
<configuration>
<system.web>
<compilation targetFramework="4.5" />
<httpRuntime targetFramework="4.5" />
</system.web>
<system.webServer>
<security>
<authentication>
<anonymousAuthentication enabled="false"/>
<windowsAuthentication enabled="true" />
</authentication>
</security>
</system.webServer>
</configuration>

  • Deploy the site to the IIS Web Server;
  • Refer to a default page via the IP address;
  • Perform the ajax request. Check the Network monitor to make sure that the request was completed;
  • Wait 1 minute;
  • Perform the same ajax request.

All the related source files are available in the attachment.

Expected Results:

The ajax request should be completed with any valid status.

Actual Results:

Dev Channel specific:

No

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Kamen M.”

      Changed Assigned To to “Venkat K.”

      Changed Assigned To from “Venkat K.” to “IE S.”

      Changed Status to “Not reproducible”

    You need to sign in to your Microsoft account to add a comment.

    Sign in