Custom cursor styling broken

Not reproducible Issue #22599141

Details

Author
Joris v.
Created
Jul 5, 2019
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
18.17763
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

We used to use the following css style to apply a custom cursor (with retina fallback). This no longer functions in the latest version of edge (18).

{
    cursor: url('cursor.cur'), auto;
    cursor: url('cursor.png') 16 16, auto;
    cursor: -webkit-image-set(url('cursor.png') 1x, url('/cursor_high.png') 2x) 16 16, crosshair;
}

The 2nd is being incorrectly parsed by the browser, resulting in the applied style being:

cursor: url(‘cursor.cur’), auto;
cursor: auto;
cursor: -webkit-image-set(url(‘cursor.png’) 1x, url(‘/cursor_high.png’) 2x) 16 16, crosshair;

where the last line has the red underlining (as in has an incorrect value). It looks like it is parsing the 2nd line incorrectly, setting the cursor back to auto.

Attachments

0 attachments

    Comments and activity

    • Hi Joris!

      Thank you for contacting us about this issue! I tested this and I was unable to reproduce the cursor problem that you are describing. Could you provide me with your version of Microsoft Edge and a minimal reproduction on a site such as jsfiddle.net?

      How to find your version of Microsoft Edge: https://support.microsoft.com/en-us/help/4027011/microsoft-edge-find-out-which-version-you-have

      Thanks,

      Zach

    • Microsoft Edge Team

      Changed Assigned To to “Zachariah L.”

      Changed Status to “Not reproducible”

    • Hi!

      For now, I will resolve this issue as "Not Reproducible". If you are still experiencing this problem then please feel free to reopen this issue with the information requested and I will resume my investigation.

      Thanks,

      Zach

    You need to sign in to your Microsoft account to add a comment.

    Sign in