HTTP redirects with CORS do not work

Fixed Issue #2336707

Details

Created
Apr 10, 2015
Privacy
This issue is public.
Reports
Reported by 0 people

Sign in to watch or report this issue.

Steps to reproduce

URL:

Repro Steps:

http://apps.caas.com/BASLTest/client

Automatically redirects. the page is REST based, so the content loads from "bc-017.us.caas.hosted-inin.com"; we use CORS to connect to the web service endpoint, "iw-017-den.us.caas.hosted-inin.com". We use an HTTP redirect to direct the client to the appropriate service URI; it is possible that multiple redirects are received with different redirect response codes (we use 302 and 307 for different purposes).

If I enable "Access data sources across domains", the site works as expected; but utilizing CORS should not need that option set.

Expected Results:

the page should load and provide a username, password login dialog. When it fails, it requests a server name only.

This functionality works in both Chrome and Firefox, but not IE 10 or IE 11.

If I enable "Access data sources across domains", the site works as expected; but utilizing CORS should not need that option set.

Actual Results:

Dev Channel specific:

No

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Tony S.”

      Changed Assigned To to “Venkat K.”

      Changed Assigned To from “Venkat K.” to “Brandon M.”

      Changed Status to “Confirmed”

      Changed Assigned To from “Brandon M.” to “David W.”

      Changed Status from “Confirmed” to “Not reproducible”

      Changed Status from “Not reproducible” to “Fixed”

      Changed Assigned To from “David W.” to “IE S.”

    You need to sign in to your Microsoft account to add a comment.

    Sign in