Issuing WebDriver requests to http://127.0.0.1:17556 fail, but http://localhost:17556 works

External Issue #3901350

Details

Created
Aug 5, 2015
Privacy
This issue is public.
Reports
Reported by 2 people

Sign in to watch or report this issue.

Steps to reproduce

The following HTTP request would fail with status code 400.

POST http://127.0.0.1:17556/session HTTP/1.1
Host: 127.0.0.1:17556
Content-Length: 57

{"desiredCapabilities": {}, "requiredCapabilities": {}}

Expected Results:

Both http://localhost:17556/ and http://127.0.0.1:17556/ should work. Plus, http://::1:17556/ should also work.

Would be nice if there is a CLI option to enable remote test execution by opening up port 17556 to remote machines.

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Mara P.”

      Changed Assigned To from “Mara P.” to “Clay M.”

      Changed Status to “Confirmed”

      Changed Assigned To from “Clay M.” to “Ben B.”

      Changed Title from “Microsoft Edge: Issuing WebDriver requests to http://127.0.0.1:17556 fail, but http://localhost:17556 works” to “Issuing WebDriver requests to http://127.0.0.1:17556 fail, but http://localhost:17556 works”

    • Similar problem with local HTTP server (Lantern Web UI).

    • Microsoft Edge Team

      Changed Steps to Reproduce

      Changed Assigned To from “Ben B.” to “IE S.”

      Changed Status from “Confirmed” to “External”

    • This is currently by design with how our server works. We do want to support this in the future so I’ve duped the work to feature work.

    • This issue has been resolved External. This means this issue may require a new feature to be implemented or other work that is more significant than a typical bug. You may be able to find more information on this issue by searching for related features on status.microsoftedge.com and uservoice.microsoftedge.com.

    You need to sign in to your Microsoft account to add a comment.

    Sign in