closing a new tab hangs the whole driver session

Fixed Issue #4804746

Details

Created
Oct 1, 2015
Privacy
This issue is public.
Reports
Reported by 5 people

Sign in to watch or report this issue.

Steps to reproduce

            driver.Navigate().GoToUrl(“http://ie-snap/scratchtests/johnjan/webdriver/ctrlClick.htm”);
            Thread.Sleep(5000);
            driver.FindElement(By.XPath("//a[@id = ‘foo’]")).Click();
            Thread.Sleep(5000);
           
            var handles = driver.WindowHandles;
            foreach (string handle in handles)
            {
                Console.WriteLine(handle);
                driver.SwitchTo().Window(handle);
                Thread.Sleep(TIMEOUT);
                driver.Close();
            }
            Console.WriteLine(“foo”);

NOTICE: in Chrome you will see the word “foo” written to the console, in Edge we just hang

EXPECT: the first tab should close and then you should see “foo” written to the console

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Steps to Reproduce

      Changed Assigned To to “Mara P.”

      Changed Title from “closing a new tab actually kills the whole driver session” to “closing a new tab hangs the whole driver session”

      Changed Status to “Confirmed”

      Changed Assigned To from “Mara P.” to “Ben B.”

      Changed Title from “closing a new tab hangs the whole driver session” to “closing a new tab hangs the whole driver session”

      Changed Assigned To from “Ben B.” to “Navin A.”

      Changed Assigned To from “Navin A.” to “John J.”

      Changed Status from “Confirmed” to “Fixed”

    • Is this fix released? I retried in the latest 3.14316 version of MicrosoftWebDriver but I’m still getting this error. Here is my system info:

      System info: os.name: 'Windows 10', os.arch: 'amd64', os.version: '10.0', java.version: '1.8.0_77'
      Driver info: org.openqa.selenium.edge.EdgeDriver
      Capabilities [{acceptSslCerts=true, browserVersion=25.10586.0.0, platformVersion=10, browserName=MicrosoftEdge, takesScreenshot=true, pageLoadStrategy=normal, takesElementScreenshot=true, platformName=windows, platform=ANY}]
      
    • This issue tracker lacking some basic features
      Fixed in version: 123
      Duplicate of issue: xxx

    • I am experiencing this exact problem with Java using driver.close(). I am using 3.14316 version of MicrosoftWedDriver.

    • It looks like this has not been fixed. Can you please reopen?

    • I still see this issue with webdriver 14393

    • Microsoft Edge Team

      Changed Assigned To to “John J.”

      Changed Status from “Fixed”

      Changed Status to “Fixed”

    • This should be fixed in current builds.

    You need to sign in to your Microsoft account to add a comment.

    Sign in