Base tag path not being applied to favicon download URL

Confirmed Issue #5083488 • Assigned to Bo C.

Details

Created
Oct 19, 2015
Privacy
This issue is public.
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

URL:

Repro Steps:

sub page example: http://unreal.community/chat/

<html>
<head>
<base href="http://unreal.community/">
<link rel="icon" type="text/x-icon" href="tmp/favicon.ico">
<link rel="shortcut icon" type="text/x-icon" href="tmp/favicon.ico">
</head>
<body>

</body>
</html>

Expected Results:

loading the favicon from the relative base tag URL.

Actual Results:

Dev Channel specific:

No

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Sermet I.”

      Changed Assigned To to “Travis L.”

      Changed Title from “Microsoft base tag” to “Base tag path not being applied to favicon download URL”

      Changed Assigned To from “Travis L.” to “Alex K.”

      Changed Status to “Confirmed”

      Changed Assigned To from “Alex K.” to “Eugene V.”

      Changed Assigned To from “Eugene V.” to “Bo C.”

    • Hi,

      I have encountered this issue as well on Edge and IE11 (at least). We are using the element to set the right base for the menu in our automatically generated static website. The href links for css and menu links work perfectly.

      However the favicon is not downloaded until the base href value is actually infront the relative URL to the favicon.

      Example:
      Does not work:

      Does work:

    • A comment where the actual examples should be rendered (although the preview showed the code examples):
      Does not work:

      
      
      

      Does work:

      
      
      

    You need to sign in to your Microsoft account to add a comment.

    Sign in