Setting URL doesn't wait to return before full navigation and switch has happened

Fixed, not yet flighted Issue #5129594

Details

Created
Oct 22, 2015
Privacy
This issue is public.
Reports
Reported by 0 people

Sign in to watch or report this issue.

Steps to reproduce

Repro is to run the below program.  Chrome passes.  Edge fails normally within a couple loops.

 

using

System;

using

System.Diagnostics;

using

OpenQA.Selenium.Edge;

using

OpenQA.Selenium.Chrome;

using

OpenQA.Selenium.Remote;

namespace

SeleniumTest

{

class

Program

{

static

void

Main(

string

[] args)

{

for

(

int

i = 0; i < 50; i ++)

{

//RemoteWebDriver

driver =

new

ChromeDriver

();

RemoteWebDriver driver = new EdgeDriver();

driver.Url =

http://www.msn.com/

;

string

url = driver.Url;

Console

.WriteLine(

"Url: "

  • url);

Debug

.Assert(url ==

http://www.msn.com/

,

"Actual url: "

  • url);

driver.Quit();

}

}

}

}

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Mara P.”

      Changed Assigned To from “Mara P.” to “Vijeta P.”

      Changed Status to “Confirmed”

      Changed Assigned To from “Vijeta P.” to “Ben B.”

      Changed Title from “Setting URL doesn't wait to return before full navigation and switch has happened” to “Setting URL doesn't wait to return before full navigation and switch has happened”

      Changed Assigned To from “Ben B.” to “Corey B.”

      Changed Status from “Confirmed” to “In code review”

      Changed Status from “In code review” to “In progress”

      Changed Assigned To from “Corey B.” to “Sam F.”

      Changed Status from “In progress” to “Fixed”

      Changed Status from “Fixed” to “Fixed, not yet flighted”

    You need to sign in to your Microsoft account to add a comment.

    Sign in