Demo failing due to https to http request

Fixed Issue #6391746

Details

Created
Feb 1, 2016
Privacy
This issue is public.
Reports
Reported by 0 people

Sign in to watch or report this issue.

Steps to reproduce

URL:

Repro Steps:

  1. startup Microsoft WebDriver Server
  2. visit https://dev.windows.com/en-us/microsoft-edge/testdrive/demos/webdriver/
  3. set parameters and click Send Request

Expected:
WebDriver server receives commands and executes it

Actual:
Since the page is loaded with https and per SOP, you can not send http request to local server, error info in chrome:
Mixed Content: The page at ‘https://dev.windows.com/en-us/microsoft-edge/testdrive/demos/webdriver/’ was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint 'http://localhost:17556/session’. This request has been blocked; the content must be served over HTTPS.

Expected Results:

WebDriver server receives commands and executes it

Actual Results:

Dev Channel specific:

No

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Mara P.”

      Changed Assigned To from “Mara P.” to “Clay M.”

      Changed Status to “Confirmed”

      Changed Title from “WebDriver doesn't work on demo page” to “Demo page is broken”

      Changed Title from “Demo page is broken” to “Demo failing due to https to http”

      Changed Title from “Demo failing due to https to http” to “Demo failing due to https to http requests”

      Changed Title from “Demo failing due to https to http requests” to “Demo failing due to https to http request”

      Changed Assigned To from “Clay M.” to “IE S.”

      Changed Status from “Confirmed” to “Fixed”

    • Thanks - we have removed that demo for now and might post a new site with an updated demo that is hosted on HTTP.

      All the best,

      The MS Edge Team

    You need to sign in to your Microsoft account to add a comment.

    Sign in