Smart Card MiniDriver and Edge External PIN type fails

By design Issue #6842710

Details

Created
Mar 11, 2016
Privacy
This issue is public.
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

URL:

Repro Steps:

  1. Install a mini driver with external Pin type defined.
  2. Access an SSL client protected web site using the minidriver smart card inserted in a reader
  3. When CardAuthenticateEx is invoked try to display a GUI using one of the above API
  4. Edge crashes, hangs or return an error depending on the API invoked.

Expected Results:

Edge should allow mini driver to display a GUI when external pin type is defined as specified by the Mini Driver specification.

Actual Results:

Dev Channel specific:

No

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Kamen M.”

      Changed Assigned To to “Sermet I.”

      Changed Assigned To from “Sermet I.” to “Vijay B.”

      Changed Assigned To from “Vijay B.” to “Eduardo B.”

      Changed Assigned To from “Eduardo B.” to “IE S.”

      Changed Status to “By design”

    • What is the solution? Is there a MS update/patch that resolves this issue?
      The smart card team had closed this issue, stating it was "By Design".

      However in my instance, I have 2 computers one works and one does not:

      Computer 1 is hardened. Edge never displays PIN GUI and crashes with Error Code 500. Could we be missing an update as we mainly push critical and security updates? If so what update?

      Computer 2 is NOT hardened but has all available updates and Edge works fine with Smart Cards Authentication.

    • Hello,

      Thank you for providing this information about the issue. This case is resolved as “By Design” due to Edge hardening and security limitations. We do not plan to release a fix for this problem currently; however, we are taking your suggestion into consideration for a future build.

      Best Wishes,
      The MS Edge Team

    You need to sign in to your Microsoft account to add a comment.

    Sign in