Edge crashes navigating to as.com subpages

Not reproducible Issue #7105954

Details

Author
Max F.
Created
Apr 4, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
13.10586
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Navigate to as.com, browse around the site. Eventually (and non-deterministically), the Edge process will crash.
0:011> k 10
Child-SP RetAddr Call Site
000000e4b4f23bc0 00007ffe30764c31 KERNELBASE!RaiseFailFastException+0x74
000000e4b4f24190 00007ffe30327ed0 edgehtml!Abandonment::InduceAbandonment+0xa5
000000e4b4f24270 00007ffe3026e12a edgehtml!Abandonment::InduceHRESULTAbandonment+0x28
000000e4b4f242a0 00007ffe301d9ef3 edgehtml!Abandonment::CheckHRESULTStrict+0x1a
000000e4b4f242d0 00007ffe301dc2b5 edgehtml!CJScript9Holder::GetPrototype+0x9b
000000e4b4f24370 00007ffe301d99b1 edgehtml!CJScript9Holder::DeferInitializeConstructor+0x69
000000e4b4f24450 00007ffe2f7530f2 edgehtml!CJScript9Holder::DeferInitWindowConstructor+0x71
000000e4b4f244a0 00007ffe2f75345f Chakra!Js::JavascriptExternalFunction::DeferredInitializer+0xaa
000000e4b4f24530 00007ffe2f7533c5 Chakra!Js::DeferredTypeHandler<&Js::JavascriptExternalFunction::DeferredInitializer,Js::DefaultDeferredTypeFilter,0,0,0>::En
sureObjectReady+0x23
000000e4b4f24560 00007ffe2f84ffe0 Chakra!Js::DeferredTypeHandler<&Js::JavascriptExternalFunction::DeferredInitializer,Js::DefaultDeferredTypeFilter,0,0,0>::Ge
tProperty+0x25
000000e4b4f245c0 00007ffe2f8854a2 Chakra!Js::JavascriptFunction::GetProperty+0x1c0
000000e4b4f24660 00007ffe2f84be05 Chakra!<lambda_d0b45bc586eac73c2f5c13928dc7a24e>::operator()+0xb2
000000e4b4f246c0 00007ffe2f84c335 Chakra!Js::DefaultScriptOperations::DefaultOperationsWrapper<<lambda_d0b45bc586eac73c2f5c13928dc7a24e> >+0xd5
000000e4b4f247a0 00007ffe301d9eec Chakra!Js::DefaultScriptOperations::GetOwnProperty+0x75
000000e4b4f24820 00007ffe301d9fb2 edgehtml!CJScript9Holder::GetPrototype+0x94
000000e4b4f248c0 00007ffe3027488f edgehtml!CJScript9Holder::InitImplicitWindow+0x92

Attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Christian F.”

    Changed Status to “Not reproducible”

  • To reproduce, try opening a bunch of the links in new tabs. Also (and this may or may not be relevant) I have Flash disabled locally.

    I take it the crash dump doesn’t provide any insight into what’s going wrong? I have plenty more, but they mostly just have the same stack.

  • This item of feedback appears to be not repro on latest builds. If you are still seeing this as an active issue please feel free to reactivate at your earliest convenience.

    All the best,
    The MS Edge Team

You need to sign in to your Microsoft account to add a comment.

Sign in