Any site with advertisements renders slowly

External Issue #7113765

Details

Author
Jack W.
Created
Apr 5, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
  • Internet Explorer
Found in build #
34.14295
Reports
Reported by 2 people

Sign in to watch or report this issue.

Steps to reproduce

  1. Load a site with advertisements: e.g neowin.net, windowscentral.com
  2. The site will load, the advertisements will try to load after
  3. You can barely scroll or do anything until it has loaded all the advertisements
    Other browsers, such as Chrome, are able to handle advertisements loading, and still render the page and allow the user to use the website as it is rendering the advertisements.

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Rico M.”

      Changed Assigned To from “Rico M.” to “Ibrahim O.”

    • Thank you for your feedback. This was a known issue in previous version of Edge but this issue has been fixed in TH2 update. Having said that we have been unsuccessful reproducing this issue on MS Edge 25.10586 Win Ver 1511. If you are missing any recent updates, could you please update your system and keep us posted about your result along with the environment you are testing. Information such as;

      Testing on Virtual or physical machine?

      Repro on Windows 10 Mobile or PC?

      What is the Windows and Edge version?
       

      All the best,
      The MS Edge Team

    • Microsoft Edge Team

      Changed Assigned To from “Ibrahim O.” to “Brandon H.”

      Changed Status to “Confirmed”

      Changed Assigned To from “Brandon H.” to “Ibrahim O.”

    • Hi Ibrahim,

      This is on the latest Insider build for Windows 10 Mobile, 14327.

      Loading sites with advertisements causes Edge to lag massively, on Continuum.

      For example, if I load neowin.net, and scroll around, it won’t scroll for around 10-20 seconds afterwards, as it tries to catch-up with itself.

    • I can replicate the issue on:

      outlook.com - whole experience is slow until the sidebar advertisements load in
      neowin.net - all actions lag and perform 10-20 seconds later until everything is loaded

    • Microsoft Edge Team

      Changed Assigned To to “Rico M.”

      Changed Status from “Confirmed”

      Changed Assigned To from “Rico M.” to “Brandon H.”

      Changed Status to “Confirmed”

      Changed Status from “Confirmed” to “External”

    • Thank you for this feedback. This is a known issue with loading content blocking input / other user actions from happening. Improving this is a significant change, but it is something we are considering in a future flight. I’m going to duplicate this bug to the planned work to improve it.

    • Thanks Brandon - do you have any estimate when work on this will commence?

    You need to sign in to your Microsoft account to add a comment.

    Sign in