IE crashes when opening developer tools (F12) when a stylesheet is loaded twice.

Duplicate Issue #7115490 • See Issue #7115476

Details

Author
Daaf S.
Created
Apr 5, 2016
Privacy
This issue is public.
Found in
  • Internet Explorer
Duplicates
See progress on Bug #7115476
Found in build #
11
Reports
Reported by 4 people

Sign in to watch or report this issue.

Steps to reproduce

IE crashes when opening developer tools (F12) when a stylesheet is loaded twice.
demo at: http://bug.pluscare.nl/20160405/
after much trimming down code it boils down to:
page.htm

<!DOCTYPE html>
<HTML>
<head>
    <title>bug</title>
    <meta http-equiv="X-UA-Compatible" content="IE=EDGE">
    <link rel="stylesheet" href="stylesheet.css">
    <link rel="stylesheet" href="stylesheet.css">
</head>
<body>
        crash when you press F12
</body>
</html>

Stylesheet.css:

@keyframes fa-spin {
  0% {
    transform: rotate(0deg);
  }
}

The same thing happens when you have the stylesheet in main page and in a sub frame:
main.htm:

<!DOCTYPE html>
<HTML>
<head>
    <title>bug</title>
    <meta http-equiv="X-UA-Compatible" content="IE=EDGE">
    <link rel="stylesheet" href="stylesheet.css">
</head>
<body>
        <iframe src="subframe.htm">
</body>
</html>

frame.htm:

<!DOCTYPE html>
<HTML>
    <HEAD>
        <TITLE>bug, subFrame</TITLE>
        <link rel="stylesheet" href="stylesheet.css">
    </HEAD>
    <BODY scroll="no">
        this is a subframe<BR>
        crash when you press F12
    </BODY>
</HTML>

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Leo L.”

    • Desktop
      Windows 10 IE11 crash
      Windows 10 Edge OK

      Laptop
      Windows 10 IE11 crash

      Server
      Windows Server 2012 IE10 OK

    • Microsoft Edge Team

      Changed Status to “Duplicate”

    • accidentally posted twice. please remove this issue and see #7115476

    • Same configuration(Win10, IE11) same behaviour (crash) when loading the same css file from outer html and from embedded iframe. Tested on two machines.

    • It happens for me with Windows Server 2012 R2 + IE11 since version 11.0.960.17495 (Update 11.0.15)

    •  

      Thank you for your feedback and sorry to hear that you are having difficulties
      with Internet Explorer. However we’re not presently working on feature bugs in
      Internet Explorer outside of security-related issues.

      Alternatively, if you have a premier support contract you can visit

      https://premier.microsoft.com

      and open a support incident and work with an engineer
      to address this issue.

      Best regards,

      The MS Edge Team

    • You know, that would be an acceptable answer if SharePoint didn’t require IE, and if it actually worked correctly. But for anyone who’s trying to theme a SharePoint app and look at, for instance the themeing of an overlay… it’s impossible.

      So that’s pretty lame, when a gazillion dollar platform has to run on an unsupported browser, and both the platform and the browser are Microsoft products.

      So what are you going to do about it, Microsoft? SharePoint 2013 gonna work on Edge anytime soon? If not, please fix IE 11 developer tools. Otherwise, all of us poor saps who have to design custom SharePoint branding that has to work on IE are hung out to dry.

      Pretty unacceptable considering the cost of SharePoint Enterprise.

    • I am developing user interfaces for C# .NET Applications using WPF WebView / WebControl. Therefore i depend on IE, too and am not able to choose a different browser.

    You need to sign in to your Microsoft account to add a comment.

    Sign in