Microsoft Edge - DOM Inspector displaying different value than what is actually rendered

Not reproducible Issue #7144721

Details

Author
OBS O.
Created
Apr 7, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
Reports
Reported by 4 people

Sign in to watch or report this issue.

Steps to reproduce

In the screenshot, the area of the screen highlighted in yellow should match what is bracketed in red. However it does not.
I suspect this is an Edge issue. The span element highlighted yellow in the DOM inspector should mirror what I’ve highlighted in yellow on the web page. Somehow what’s represented in the DOM is not updated properly within the web browser. Any help/tips here would be greatly appreciated.

Attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Travis L.”

    Changed Assigned To from “Travis L.” to “Brad E.”

  • Hello,

    Thank you for the feedback. Would you be able to create an account on this site for testing purposes? We would need to be able to see the code that is responsible for this so that we can narrow down the cause of the problem.

    All the best,
    The MS Edge Team

  • Unfortunately that won’t be easy. This is a private site hosted on an internal VPN. Maybe we can set up a screen share?

  • If you could do a screen capture, or possibly create a reduced repro that would be the most helpful aside from creating an account for us to troubleshoot with.

    All the best,
    The MS Edge Team

  • Microsoft Edge Team

    Changed Status to “Not reproducible”

  • As there has not been an update to the item recently, it will be closed out as not repro.

    Please feel free to reply to this item, or open a new feedback in our issue tracker at your earliest convenience should you feel this needs to be looked into further.

    All the best,
    The MS Edge Team

  • We were able to reproduce this issue on a site using knockoutjs.
    The dom is updated using an observable function and correctly updates the markup, but the rendered page is not updated.
    We only noticed this happening on the latest version of IE Edge (25). It worked correctly on IE Edge 20.

    Here are steps to reproduce the issue:

    1. Go to: https://www.globalknowledge.com/us-en/course/87526/programming-in-c/offerings?format=Classroom+Live
    2. Click “Add to Cart” for any of the items.
    3. Notice that the count in the top bar does not increase.
    4. Inspect the count and see that the value does not match what is rendered on the screen.

    If you try this in any other browser then you’ll see how it should work.
    If you double click the "Cart (0)" a couple times in the dropdown sometimes it does cause the value to update.
    The count in the dropdown and top bar use the same pureComputed observable, but only the one in the dropdown every changes and when it does change its delayed.

    I can force a re-render if I do something like "$(‘.cart-number’).text($(‘.cart-number’).text())" on the element.

  • sorry, the Edge link is wrong, this is the right one: https://drive.google.com/file/d/0B7jbL0NBHsVJZEtob3NkNG1oNFE/view?usp=sharing

You need to sign in to your Microsoft account to add a comment.

Sign in