Link tag with target="_blank" doesn't work in extension popup page

Fixed, flighted Issue #7191389

Details

Created
Apr 13, 2016
Privacy
This issue is public.
Fixed in build #
15043
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

  1. Create a sample extension with popup page, in popup page, add the following element:   <a href="http://www.microsoft.com" target="_blank">Test</a>
  1. load the extension and click the link

Expected: A new tab is created with the target url

Actual: nothing happens

Workaround:
The only workaround is to send a message to the background script and have the background script open a new tab using the browser.tabs API that navigates to the URL.

Alternate repro
see
Bug 8932685

Please see other feedbacks in userfeedback VSO for feedbacks that are tracked by this work item.

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Chee C.”

      Changed Assigned To from “Chee C.” to “Cameron S.”

      Changed Status to “Confirmed”

      Changed Steps to Reproduce

      Changed Title from “Link tag with target="_blank" doesn't work in popup page” to “Link tag with target="_blank" doesn't work in extension popup page”

      Changed Steps to Reproduce

      Changed Status from “Confirmed” to “In code review”

      Changed Assigned To from “Cameron S.” to “Yajie X.”

      Changed Status from “In code review” to “Fixed, not yet flighted”

      Changed Steps to Reproduce

      Changed Status from “Fixed, not yet flighted” to “Fixed, flighted”

    You need to sign in to your Microsoft account to add a comment.

    Sign in