requestMediaKeySystemAccess fails if more than one video MIME type is specified

Fixed Issue #7223299

Details

Author
Joey P.
Created
Apr 15, 2016
Privacy
This issue is public.
Reports
Reported by 2 people

Sign in to watch or report this issue.

Steps to reproduce

If you call requestMediaKeySystemAccess() in Edge with more than one video MIME type in videoCapabilities, the query fails with NotSupportedError, even if the two individual MIME types are supported on their own. The query should succeed if either of the two MIME types is supported.
Demo:
https://storage.googleapis.com/shaka-demo-assets/_bugs/edge-mediakeys-query/index.html
Expected results:
video/mp4; codecs="avc1.640015": PASS
video/mp4; codecs="avc1.64001e": PASS
either: PASS
Actual results:
video/mp4; codecs="avc1.640015": PASS
video/mp4; codecs="avc1.64001e": PASS
either: FAIL (NotSupportedError)

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Venkat K.”

      Changed Assigned To from “Venkat K.” to “Nishant N.”

      Changed Assigned To from “Nishant N.” to “Jerry S.”

      Changed Status to “Fixed”

    • When was this reported, and in which version was this fixed ?

    • I reported this in April. The issue affected Edge 13. Microsoft has not told us when it was fixed.

    • We do not know exactly when it was fixed but it is fixed in later builds. I was able to repro in 14339 but am no longer able to. Something between 14339 and 14393 fixed this.

    You need to sign in to your Microsoft account to add a comment.

    Sign in