html drop downs (select/option) with empty first option

Not reproducible Issue #7279425

Details

Author
Humair Q.
Created
Apr 20, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
Reports
Reported by 2 people

Sign in to watch or report this issue.

Steps to reproduce

following html does not render properly in MS Edge 37.14316
<select > <option></option> <option value="act">ACT</option> <option value="nsw">NSW</option> <option value="nt">NT</option> <option value="qld">QLD</option> <option value="sa">SA</option> <option value="tas">TAS</option> <option value="vic">VIC</option> <option value="wa">WA</option> </select>

Attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Ibrahim O.”

  • Thank you for your feedback. We have been unsuccessful reproducing this issue on MS Edge. Could you please provide us more details  about this issue along with a link or project files that can can demonstrate the issue. Please also let us know which platform you are testing this issue (Desktop /Mobile)

    Best regards,
    The MS Edge Team

  • Microsoft Edge Team

    Changed Status to “Not reproducible”

  • As we have not received further information on how to repro
    this item of feedback - we will resolve it as not repro. Should you have the
    details needed in order for us to reproduce this problem in our test
    environments please feel free to reactivate this issue at your earliest
    convenience.

    All the best,

    The MS Edge Team

  • I have reproduced this issue. There may be other ways to reproduce but this is how I have been able to reproduce it.

    The rendering gets messed up when you apply a font in stylesheet on all elements i.e. ‘*’ and have an empty option in select at the top. e.g.

    • {
      font-family:’Segoe UI’, Arial, Helvetica, sans-serif;
      }

    Volvo

  • In addition to my above note (here is a sample code which produces this issue):

    <html>
    <head>
    <style>
    *{font-family: 'Segoe UI’, Arial, Helvetica, sans-serif;}
    </style>
    </head>
    <body>
    <select>
    <option></option>
    <option value="volvo">Volvo</option>
    </select>
    </body>
    </html>

  • Once again, in addition to my above note ‘Segoe UI’ seems to be the culprit in my above sample.

You need to sign in to your Microsoft account to add a comment.

Sign in