Assert 90d.90d @ microsoftedgecp.exe!edgehtml.dll!`TextInput::TextInputLogging::Instance'::`2'::`dynamic atexit destructor for 'wrapper''

Fixed Issue #7422991

Details

Created
May 3, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
11
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Repro:

<body onload=o=open();o.close();Object.getOwnPropertyDescriptor(o,"toString")>

As usual, the second file attached contains BugId information for this issue.

Attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Brad E.”

  • Hello,

    This doesn’t seem to crash Edge on my local workstation - even though I am using an older version of Edge (but still 10586). Are any other steps needed to see the crash happen?

    Thanks for the feedback.

    All the best,
    The MS Edge Team

  • Not that I am aware off. Are you loading it from a local webserver?

    Either way, the BugId information has a stack trace, which may help you pinpoint the code path that caused the issue. However, the two most important (and highlighted) entries in that stack may have the wrong symbol because of compiler optimizing multiple similar functions into one.

    That file also shows that Edge outputs the following right before the crash:
    inetcore\apfilter\src\util\unmanaged\core\src\useraccountstore.cpp(48)\ieapfltr.dll!00007FFCA2886589: (caller: 00007FFCA2886B7E) Exception(1) tid(1204) 80040154 Class not registered

    I hope this helps.

  • Microsoft Edge Team

    Changed Status to “Fixed”

  • Hello,

    This does not repro in the latest internal builds (14339.1000) but does repro in 10586.  As a result of this the item will be resolved as fixed.

    All the best,
    The MS Edge Team

You need to sign in to your Microsoft account to add a comment.

Sign in