extension files added via dynamic iframes are not cleaned up until Edge is restarted

Won’t fix Issue #7433606

Details

Created
May 4, 2016
Privacy
This issue is public.
Reports
Reported by 0 people

Sign in to watch or report this issue.

Steps to reproduce

  1. Install any extension
  2. Click on the browserAction icon
  3. Sign in with a test account
  4. Navigate to Wikipedia
  5. Launch F12 to debug the page
  6. Click on the browserAction icon to see the fake popup, which is actually an iframe on the page (you might have to click this twice)
  7. Click on the browserAction icon to dismiss it, and repeat steps 6-7

Observed:
js files loaded as part of the iframe are not removed

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Leo L.”

      Changed Assigned To from “Leo L.” to “Rob L.”

      Changed Status to “Confirmed”

      Changed Assigned To from “Rob L.” to “Scott S.”

      Changed Steps to Reproduce

    • The Edge team is working on a fix for a future update.

    • Microsoft Edge Team

      Changed Assigned To from “Scott S.” to “Chee C.”

      Changed Status from “Confirmed” to “Won’t fix”

    • Hi!

      We have made a decision to scope bug fixing on the current Edge product to critical security and reliability issues, and the minimum necessary to service in-market customers (RS4, RS5 and 19H1), in order to focus on high quality delivery of the new Edge based on open source.  I am resolving this bug Won’t Fix to let you know of this explicitly, instead of simply keeping the bug active. 

      Thanks,
      Zach

    You need to sign in to your Microsoft account to add a comment.

    Sign in