navigator.requestMediaKeySystemAccess doesn't accept robustness

Fixed Issue #7439722

Details

Author
Jacob T.
Created
May 4, 2016
Privacy
This issue is public.
Reports
Reported by 2 people

Sign in to watch or report this issue.

Steps to reproduce

When querying EME using navigator.requestMediaKeySystemAccess, it doesn’t accept any robustness level. If one of the videoCapabilities or audioCapabilities contain a robustness value, even if it is the empty string (the default), it will indicate that it is not supported.

https://jsfiddle.net/o4rqfv06/2/

If you run that, it will display a count of 0, which is not intended. This suggests that it cannot decrypt the content type. An empty robustness level indicates that any robustness level can be used. So when EME returns without that in the capabilities, it suggests that it is not supported.

Commenting out the line setting the robustness will return the correct result. It will display 1 supported content type of video/mp4. When the robustness is set to the empty string, it should be treated the same as missing.

See: https://w3c.github.io/encrypted-media/#widl-MediaKeySystemMediaCapability-robustness

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Status to “Fixed”

    • Hello,

      Thank you for the feedback on Edge and the repro.  In testing this out on internal builds I show this as being fixed. The specific build being tested is 14339.1000.  As a result of this, the item is being resolved as fixed.

      All the best,
      The MS Edge Team

    You need to sign in to your Microsoft account to add a comment.

    Sign in