ASPXFORMSAUTHCOOKIE not set on ajax request

Fixed Issue #7513876

Details

Created
May 10, 2016
Privacy
This issue is public.
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

When calling a REST service via ajax that upon successful login sets the forms auth ticket, the cookie is returned in the response. Any subsequent ajax calls DO NOT include the auth cookie in the request. Only after refreshing the browser auth cookies are included in the requests.

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Brad E.”

    • Hello,

      Thanks for the feedback. Which browsers are affected by this? Do you have a reduced case setup to demonstrate the behavior that you have mentioned?

      All the best,
      The MS Edge Team

    • This only affects Edge. It works fine in Chrome, Firefox, Safari, iOS, android.
      Don’t have a case but you can see it here:
      goto http://swipesho.ego7.com
      login using usr: dude@dude.com psw: Duderino7
      You will see that the login gets stuck as the REST get request returns nothing
      Then if you reload the app it has the cookie

    • Trying to upload screen shot but keep getting error!

    • Microsoft Edge Team

      Changed Status to “Fixed”

    • Thanks for your patience and providing me with the details needed for repro.

      This appears to have been fixed in the latest builds of Win10 / Edge. When I tested this out on multiple computers running Windows Insider Fast build 14361.0 and higher - the login form processed successfully.

      If I test this on any computer running 10586 - the login does not work.  I would recommend waiting until this is fixed with our latest ‘Redstone’ update that should be pushed out soon.

      Since this was broken in 10586 and fixed in 14361 (or possibly sooner) I will resolve the item out as fixed. If the issue still happens after updating to RS1 (or testing with Insider Preview VM’s) please feel free to update this item and provide relevant details so that we can investigate further.

      All the best,
      The MS Edge Team

    You need to sign in to your Microsoft account to add a comment.

    Sign in