Cannot open some PDFs from a UNC network file share

Not reproducible Issue #7553879

Details

Author
Bart D.
Created
May 13, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
Reports
Reported by 8 people

Sign in to watch or report this issue.

Steps to reproduce

  1. Copy a pdf file to a file share on a remote machine.
  2. Dbl-click to open in Edge.

Result: an error page with the text below, in an Edge browser window showing “file://192.168.1.100/Documents/Vehicles/2016%20Lexus%20ES%20300h/img05132016_0001.pdf” in the URL/search bar:


Hmm, we can’t reach this page.

Try this
•Make sure you’ve got the right web address: ms-appx-web://microsoft.microsoftedge/assets/errorpages/dnserror.html#file://192.168.1.100/temp/img05132016_0001.pdf
•Refresh the page
•Search for what you want


Only some files expose this problem. I’ve attached one to this report.

I only hit this when the file is on a remote machine’s file share; if I try to open the file on a local share like \localhost\c$\temp, it works. The current user has full control in share-level and NTFS permissions. For example, immediately after reproducing this I deleted the file from the share in Explorer, without any elevation prompt.

Attachments

2 attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Ibrahim O.”

  • Thank you for your feedback. Could you please verify your OS build and Edge version? 
    For OS build you can type “winver” in start menu then press enter. You can check you Edge version by opening the Edge menu under the settings option you will see the About this app section. 

    If you see this issue in any version above 10586.318 please send us your procmon logs by using Process Monitor tool, you can download in the following link https://technet.microsoft.com/en-us/sysinternals/processmonitor Please let us know if you will need more assistance.

    Best regards,
    The MS Edge Team

  • Hi Ibrahim - I’m on Windows 10 build 10586.318. Will capture and attach procmon soon

  • Sorry, this site seems to be down. When I try to attach a new file with the procmon output I get:

    The page you are trying to access isn’t available right now. Please try again soon.
    Error correlation ID: 3685d29a-4937-4c37-80a3-5896888c6770
    Error correlation vector: +OVJaDpim0eQseKB.1
    App server: microsoft-edge
    Time: 28 May 2016 10:29:52 -07:00

  • Sorry for the inconvenience. Could you please try re-uploading your log file. If you are still facing any difficulties uploading your file please keep us posted we will be happy to assist you.

    All the best,
    The MS Edge Team 

  • I too have a similar issue and have posted steps on how to recreate the issue on my blog http://scriptimus.wordpress.com/

    It makes sense to link it here rather than raising an new issue.

  • Please follow this post to recreate this issue that is Windows 10 Edge specific. My post rules out Group Policy, Domain, Permissions, 3rd party tools etc.

    Direct link here: http://scriptimus.wordpress.com/2016/08/22/unable-to-open-pdf-in-edge/

  • I have the same issue with all my pdf files on network shares, i attach some image with the error, with other pdf viewer there is no problem on same files.

  • Sorry for the delayed response, and appreciate the additional info and repro steps. I am still having trouble to recreate the issue which is tested on build 14393 lastly and I can open the pdfs successfully. (Attachment,  repro.GIF)  Also I see Andrew’s link has clear description for recreating the issue, however still not able to repro although I have used the pdf provided on this feedback. Please let me know if we can reduce the repro steps or provide more details such as about GPO settings, or the common environment setup the ones who can repro this issue. Or any details that can be related to the issue. To reduce repro, could you please also confirm this issue can repro with all pdfs or only certain pdfs. Also please let me know if this issue can be repro in the same environment with other filetypes such as html. It is always possible we may missing something in the repro steps. Please keep us posted about your progress resolving this issue we will be happy to assist you.

    Lastly, we can do desktop sharing session to collect more details about the issue if necessary.

    All the best,
    The MS Edge Team  

  • Hi, I’m able to reproduce the same issue using server fqdn name instead of netbios name.
    I’m a software developer and a IT so all the time I change to another network fqdn is needed.
    My path is

    file://bbsrv.bbros.lan/BBros/Documenti/Preventivi/20161108-BBros%20P162.pdf

  • Ibrahim, here’s the repro: Put a pdf file on a remote file share, open that share in Windows Explorer using a fully-qualified domain name, e.g. "\mymachine.redmond.corp.microsoft.com\mysharename", then dbl-click the file to open in Edge.

    If it opens, that’s probably because you previously set that machine as a trusted site (Tools -> Options -> Security). By default it wouldn’t be a trusted site, and the open attempt would fail.

  • To make things clear, I have tested this issue again on a clean install VM accessing to a server on a different domain network with FQDN which pdf successfully loaded.  
    Being said that, I am trying to make sure we are not missing any client side configuration such as authentication issues, before I escalate the issue for further review and processing.

    Could you please let me know do you see any error or warning logs in the console while trying to open the pdf. And could you also please test the same failing URL with “http://” instead “file://” see if that fails to load same pdf URL? 

    Additionally, it would help if you can provide us the fiddler trace, you will need to configure fiddler for remote connections. 
    How to : http://docs.telerik.com/fiddler/Configure-Fiddler/Tasks/MonitorRemoteMachine

    NOTE:
    Please do not visit any sites that contain personal or sensitive data such as
    passwords or financial data while collecting the trace. 

    Best regards,
    The MS Edge Team

  • Ibrahim, I can’t believe you are still struggling to replicate the issue despite the detailed steps I’ve given to recreate the issue on my blog.

    I was able to resolve it in PROD by adding the DNS suffix to my trusted sites list.

  • Hello Andrew,

    Since I was focused on Edge app level testing, I was missing the part overriding DNS which seems like created the repro for me. I will escalate the issue to the appropriate team for further processing.

    Thank you all for your contribution.

    Best regards,
    The MS Edge Team

  • Great news. Thanks Ibrahim.

  • Microsoft Edge Team

    Changed Assigned To to “Rico M.”

    Changed Assigned To to “Amit K.”

    Changed Assigned To from “Amit K.” to “Vyankatesh G.”

    Changed Status to “Confirmed”

    Changed Status from “Confirmed” to “Not reproducible”

  • Ibrahim, I suppose now that it is handed over to another you can no longer report on updates? Or will the team report back here since it is still listed here? Could you please inform us on the internal process once an issue is escalated to another team.

    And the status still says Not Reproducible although your comment above states you were finally able to reproduce the issue. Could you update this?

    And finally, you may have had some difficulty reproducing the error, thousands of potential Edge users have not. This is a serious issue (just see these bing results: https://www.bing.com/search?q=edge%20pdf%20network%20drive), please make it get some attention!

  • Hello,

    Thank you for providing this information about the issue. After thorough testing, we are unable to reproduce this problem in Edge. Please test this behavior in our latest insider build 15063 and relay the results to us.

    Best Wishes,
    The MS Edge Team

  • It shouldn’t be the case that the for a file:// address that it requires the FQDN be added to the site zone 1 (local intranet) either manually in IE or using GP (User\Policies\Administrative Templates\Windows Components\Internet Explorer\Internet Control Panel\Security Page\Site to Zone Assignment List). With a PDF, for example, on the NETLOGON share requiring the domain name to be added, which then gets an “*.” attached to the start of the entry automatically.

You need to sign in to your Microsoft account to add a comment.

Sign in