Any kind of delay causes Edge 13 to fail loading the page

Fixed Issue #7613362

Details

Author
nick d.
Created
May 19, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
13
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

If you try to use any kind of SetTimeout or delay feature (see: jquery or velocity) on window.load() Edge 13 will error and spit out a “This page is having a problem loading” message.

You can reproduce this by simply doing something like the following, using the latest version of jQuery and Velocity.js:

$(window).load(function() {
  $('.loader').velocity({
    opacity: 0
  }, {
    delay: 800,
    complete: function() {
      $('body').addClass('loaded');
    }
  });
});

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Brad E.”

    • Hello,

      I have not been able to repro this as you have described it.  Can you take the sample I have here and alter it to demonstrate the problem, please?

      Link to repro:
      http://ec2-52-11-5-162.us-west-2.compute.amazonaws.com/repro/jsf.html

      All the best,
      The MS Edge Team

    • You aren’t using the latest version of jQuery 2.x, please try it with 2.2.3.

      If you’d like to see a production view of this, check this site: http://splash.resa.nickdimatteo.com

    • Any updates on this? Only seems to affect Edge 13. This is hugely problematic, for such a simple script.

    • Microsoft Edge Team

      Changed Status to “Fixed”

    • Sorry about the delay. It seems that this has been fixed in the latest builds of Win 10 / Edge. I tested our insider fast version 14352.1002

      This means that when Redstone 1 (RS1) launches this issue should correct itself.

      We do appreciate the feedback on Edge and look forward to more feedback from you in the future.  For now, the item will be resolved as fixed (since it is broken in 10586 and fixed in 14352.1002).

      Best regards,
      The MS Edge Team

    You need to sign in to your Microsoft account to add a comment.

    Sign in