PDF in iframe can't be printed

External Issue #7801755


Sadjad B.
Jun 6, 2016
This issue is public.
Found in
  • Microsoft Edge
Found in build #
Reported by 18 people

Sign in to watch or report this issue.

Steps to reproduce

Since Edge took over PDF rendering, if you have a PDF document in an iframe, a user can’t print the document easily.

The context menu only has “Save As” as an option.

The bug was originally reported at


0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Christian F.”

      Changed Assigned To to “Amit K.”

      Changed Status to “External”

    • We have added this feature in future builds of Edge. This feature should be available for RS2 but we are not able to provide more info other than that.  Thanks for the feedback and we hope that you continue to provide us with more in the future!

      All the best,
      The MS Edge Team

    • Precisely because of this problem, our students can not use the Edge Browser. I think it’s too late to incorporate the feature until RS2.

    • I have installed the Windows 10 Creators Update (1703 / RS2) and can confirm that this issue is NOT solved after installation, still no option other than "Save as".

      Is an update for Edge required besides the RS2 update?

    • It would really be time for a solution. All browsers can do this, only Edge does not.

    • If have some clues on what might be causing this issue

      In our company we use a OKI ES-7470 MFP laser printer which requires a user to fill user/password authentication form on every print session.


      • When I print a PDF using EDGE, authentication is requested, I fill using my UserName/Pass, print job is completed, but it kept Pause state on printer, not visible on printer panel, but visible thru the printer’s browser administration page
      • If I open the same PDF out of EDGE, authentication and printing process is successful

      Possible cause:
      Print from Edge does not respect user provided authentication, since it replaces UserName by "Printope", which is not user defined on that printer

      I would be glad to cooperate with Microsoft if one is interested

    • @Júlio N.

      The problem you are describing is unrelated to this one, this issue is about the non availability of a toolbar or context-menu when loading a PDF onto an existing page with means off an IFRAME or EMBED tags.

      Brad E. posted on September 6th, 2016 that this would be fixed in the RS2 build of windows 10, which turns out is not the case.

    • We are also experiencing problems with printing PDF’s in iframe / object tags in Edge. Please fix soon, this was a breeze in all other browsers, even IE! In our situation we are trying to print a pdf stored in an iframe inside an object tag using javascript.

      //things I’ve tried:
      parent.document.getElementById(“myFrame”)[0].contentWindow.document.execCommand("print", false, null); //doesn’t work in Edge

      document.getElementById(‘myFrame’).print(); //doesn’t work in Edge

      $(‘#dentalProposalFrame’)[0].contentWindow.print(); //doesn’t work in Edge

    • Besides of there is no menu for print pdf document through right click, because there is only SAVE AS option, which is strange, there is another bug. It concerns to print preview if you have pdf object inside iframe. In IE11 it is working properly, but in Edge instead of print preview, the document has been just displayed without any action…

      We use this javascript command in combination with Telerik report generation
      Hashtable deviceInfo = new Hashtable();
      deviceInfo[“JavaScript”] = "app.toolbar=false;this.zoom=90;this.print({bUI: true, bSilent: true, bShrinkToFit: true});";

      Please provide to use some workaround or fix.

    • Still not fixed in fall creator update ?!?

    • can confirm this is also an issue for all development using displaying PDF within EDGE for All Concerns I am currently implementing.

    • Is it worth waiting for Microsoft addressing this Edge browser’s preview/print issue. Its not a rocket science. its very fundamentals where other browsers are capable but Edge is not. This thread is going already more than 2 years but no resolutions from Edge browser team. Any workaround is there at least?

    • This is still an issue in Edge 41.16299.248.0

      Could we get a comment from the Edge team if this is still being worked on or if the issue is simply forgotten ?

      Regards Anders O

    • In Windows 10 v1803 it works. Use the right mouse button.

    • Hallelujah, it’s true. Now it works:-)

    • I got around this issue by right clicking the PDF link and opening it in a new tab.
      Then Right click on the opened Document, and choose “Show or Hide Toolbar” then printing from there.

    • Or, I dunno, maybe we could have the same toolbar show up in the iFrame that appears when opened directly… You know, like every other implementation seems to do and people are familiar with.

    You need to sign in to your Microsoft account to add a comment.

    Sign in