Selection not restored correctly into the editor

Fixed Issue #7907430

Details

Author
Tomasz J.
Created
Jun 16, 2016
Privacy
This issue is public.
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Steps to reproduce

  1. Open Media Embed sample ​http://sdk.ckeditor.com/samples/mediaembed.html
  2. Delete existing content, add few paragraphs of text.
  3. Embed a video in between paragraphs by using Media Embed dialog.
  4. Double click on video to open Media Embed dialog.
  5. Press ESC or click on Cancel button.

Expected

Focus is restored correctly to the editor (widget with media embed is still focused).

Actual

Focus is restored into the last paragraph inside the editor.

Other details

Issue is reproducible in Edge 25.10586.0.0, but no longer reproducible in Edge 37.14316.1000.0 (Windows 10 preview).

Connected issue in CKEditor 4 bug tracker: http://dev.ckeditor.com/ticket/14570

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Brad E.”

    • I do not have that exact version that you are testing with and claiming it has been fixed.

      I’ve tested this on our latest builds (14395 to be exact) and am showing this as still repro.

      Are you able to confirm / deny this on your end before we look into this further?

      All the best,
      The MS Edge Team

    • Yes, it seems to be reproducible on 14395.

    • Microsoft Edge Team

      Changed Assigned To to “Amit J.”

      Changed Status to “Confirmed”

      Changed Status from “Confirmed” to “Not reproducible”

      Changed Status from “Not reproducible” to “Fixed”

    • We are resolving this issue out as fixed since we are not able to repro this item any longer in the anniversary update (build 14393).

      Looking forward to more feedback from you in the future!

      All the best,
      The MS Edge Team

    You need to sign in to your Microsoft account to add a comment.

    Sign in