PDF Contents of an iframe are not hidden when using css to set iframe to "none" in enterprise mode of IE11 and windows 8

Won’t fix Issue #8040433

Details

Author
yizhang y.
Created
Jun 30, 2016
Privacy
This issue is public.
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Assume that you use Internet Explorer 11 and Enterprise Mode on Windows 8. You have an iFrame a webpage. In this situation, when you click the button to set the iframe display style to “none,” the contents of an ActiveX control or any other control that loads in the iFrame are not hidden. For example, a PDF document in the ActiveX control is not hidden.

I also try to use Div element to wrap the iframe and set the div element to "display: none". Still not working

Similar issue found in https://support.microsoft.com/en-us/kb/2833068

Please check my testing page

Attachments

2 attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Ibrahim O.”

    Changed Status to “Won’t fix”

  • Thank you for your feedback. We are sorry to hear that you are having difficulties with Internet Explorer. However we’re not presently working on feature bugs in Internet Explorer outside of security-related issues.
    Alternatively, if you have a premier support contract you can visit https://premier.microsoft.com and open a support incident and work with an engineer to address this issue.

    Best regards,
    The MS Edge Team

You need to sign in to your Microsoft account to add a comment.

Sign in