PDF viewing in Microsoft Edge

Fixed Issue #8121462

Details

Author
Deval S.
Created
Jul 8, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

In a ggplot2 graph with a Z variable included in the legend, the colors for that legend are not visible when opening the PDF in Microsoft Edge (using the local file path). This is only true when rendering the plots using CairoPDF, and viewing the resulting PDFs in Microsoft Edge. In any other browser it looks fine.

---
output: pdf_document
---

```{r setup, include=FALSE}
knitr::opts_chunk$set(echo = TRUE,dev='CairoPDF', cache = F)
```

```{r, out.width="13.8cm", out.height="15cm", echo=FALSE, results='hide',
message=FALSE, warning = FALSE}
require(ggplot2)
x <- c(1, 2, 3, 4, 5)
y <- c(2, 3, 4, 5, 1)
z <- c(5, 3, 2, 6 ,2)
plottingdf <- data.frame(cbind(x, y, z))
ggplot(data = plottingdf, aes(x = x, y = y, z = z)) + 
stat_summary_hex(bins = 4) +
scale_fill_gradient2(low="red", mid="blue", high="green", 
                     na.value=NA, midpoint=3.5, name="Third Variable", 
                     breaks=c(1:7), labels=c(1:7), limits = c(1, 7)) +
theme_bw()
```

Attachments

2 attachments

Comments and activity

  • Microsoft Edge Team

    Changed Status to “Fixed”

  • This has been fixed in the latest build of Win 10 / Edge. The item will be closed now as fixed. I am attaching a screenshot demonstrating the behavior I see showing it is fixed.

    Thank you for the feedback!

    All the best,
    The MS Edge Team

You need to sign in to your Microsoft account to add a comment.

Sign in