max-width of 100% doesn't maintain aspect ratio of image

Fixed Issue #8138939

Details

Author
Joel L.
Created
Jul 11, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
  • Internet Explorer
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Open this fiddle in all browsers:
https://jsfiddle.net/jmlear/rhteszca/

Notice in IE and Edge the image is not rendered properly.
IE- Image width is adjusted, but not the height
Edge- Image is rendered extremely small (much smaller than the width of the container)

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Brad E.”

    • Hello,

      I am not able to repro this as you have described. Here is a screenshot showing Edge 10586 and Chrome Canary 54 side-by-side:

      https://1drv.ms/i/s!Aj5TlyX5MkUmhMcSOCgjotk_pPZVWg

      Please let me know if you are doing anything specific in order to make this repro.

      All the best,
      The MS Edge Team

    • Hi Brad,

      I’m not sure what your Edge version means. When I go to settings my version is listed as Microsoft Edge 20.10240.16384.0

      Were you testing on a development version of Edge? If so, is there a way for me to test on this version?

      Thanks!

    • Sure, that is a great question.  With that information, you are on 10240 (this was the original version that was shipped with Win 10). You can test different versions by using a virtual machine.  You can find these here:https://developer.microsoft.com/en-us/microsoft-edge/tools/vms/

      There are a variety of reasons that could explain why you are using the RTM, or original version of Edge (current public stable is 10586).  Including work / network administrator settings, and many more. You should be able to navigate to your updates section and install the newest updates which will give you a higher version number. If it says that none are available there is likely something preventing you from getting the newest version. 

      You can see different versions and their changes located here:
      https://developer.microsoft.com/en-us/microsoft-edge/platform/changelog/

      Hope this helps.

    • Hello,

      This item of feedback will be closed out soon as not repro. Do you still need further assistance? Will be happy to lend a hand if so. 

      All the best,
      The MS Edge Team

    • Hi Brad,

      I have been able to test this on the updated version of Edge and it is working correctly, but I am still seeing this issue in Internet Explorer 11 even if I use -ms-interpolation-mode: bicubic.

      Is there a way to get this to work in IE as well?

      Thanks,
      Joel

    • Microsoft Edge Team

      Changed Status to “Fixed”

    • Not that I am aware of, unfortunately.

      Also it is worth noting that we are not working on IE feature bugs any longer unless they are security related. Alternatively,
      if you have a premier support contract you can visit
      https://premier.microsoft.com

      and open
      a support incident and work with an engineer to address this issue.

      Since it does not repro in Edge and we are not addressing IE feature bugs (unless they are security related in nature…) we will resolve the item as fixed (based on the fact that it is broken in IE and working in MS Edge). Sorry that I could not be of more assistance on this exact issue you are facing in IE :(

      All the best,
      The MS Edge Team

    You need to sign in to your Microsoft account to add a comment.

    Sign in