Issue with Font Awesome icons rendering in Internet Explorer 11.4xx.xxxxx.x

Won’t fix Issue #8249857

Details

Author
Matthew M.
Created
Jul 22, 2016
Privacy
This issue is public.
Found in
  • Internet Explorer
Found in build #
11
Reports
Reported by 2 people

Sign in to watch or report this issue.

Steps to reproduce

Encountered and issue with Internet Explorer 11 on Windows 10 where custom web fonts (specifically Font Awesome - http://fontawesome.io/icons/) are not rendering. We notice that this is isolated to Internet Explorer versions starting with 11.4 (11.420.10586.0, 11.494.10586.0) and these versions only seem to appear in Windows 10.

To replicate issue, use one of these versions of Internet Explorer and navigate to the link provided above for the list of Font Awesome fonts. You will see the text labels for the fonts (icons) that are listed but the actual font (icon) to the left is not rendered.

When inspecting the console displays the following:
CSS3111: @font-face encountered unknown error.
fontawesome-webfont.ttf

The Inspect Element CSS displays a crossed out content attribute (please see attachment).

This appears to be a bug with the browser as all other versions and browsers appear to be rendering the fonts (icons) fine.

Is this a known issue and will there be plans to resolve this?

Attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Brad E.”

  • Hello,

    I have attached a screenshot showing what I see on the version of IE you have described. Could you provide more details regarding your environment so that we can look into this in more detail.

    All the best,
    The MS Edge Team

  • Hi Brad,

    Thanks for the quick response. We have tried in different environments, office wifi (on a domain controller), home, cellphone wifi hotspot.

    Tried with 2 machines that have IE build 11.494.10586.0 and 3 machines with IE build 11.420.10586.0. We also have a client that has reported their whole head office is having the same issue.

    Please find attached a screenshot of what we get, same build of IE. I’ve also attached a screenshot of the System About. If there is anything else specific I can provide please let me know.

    Regards

    Steve

  • Microsoft Edge Team

    Changed Status to “Won’t fix”

  • Happy to help out. Well, I do not have anything to conclude unfortunately.  But, I do have at least some pointers which might help narrow down the cause of the problem.  Here are a couple of things to note:

    We know that this is for sure an isolated incident based on my repro.  

    You might want to try a complete reset of the IE settings in a virtual machine or non-production machine.  I say this because in my IE Security Settings, if I turn disable “Font download” I can repro the problem.

    Additionally, there are a few posts I found that claim this is related to the font being raw OpenType which does not have installable embedding rights. This is a prerequisite for raw OpenType fonts to work (to my knowledge).

    It could be a TypeKit issue, as well.  As I read about here:
    https://github.com/typekit/webfontloader/issues/332
    Maybe they could offer some reasoning or insight.

    There is a possible workaround available on StackOverflow in regards to OpenType fonts as well:
    http://stackoverflow.com/questions/16157028/css3111-font-face-encountered-unknown-error-from-web-server-works-normally

    In summary, we feel that this is either an issue not in our control (since I cannot repro) and at best a Won’t Fix item since IE feature bugs are no longer being worked on - unless they are security related. I hope that this helps in some capacity. Also the item does not repro in Edge which is our main area of focus on this Issue Tracker.

    All the best,
    The MS Edge Team

  • Thanks Brad, after your response I posted the same issue to GitHub and received a reply with the following link.

    https://github.com/FortAwesome/Font-Awesome/wiki/Troubleshooting#fonts-not-rendering-properly-running-windows-10

    Further down is the link to the Windows 10 “feature” that is causing the problem.

    https://technet.microsoft.com/itpro/windows/keep-secure/block-untrusted-fonts-in-enterprise#Turn_on_and_use_the_Blocking_untrusted_fonts_feature

    It appears this is enabled by default and when disabled the fonts (Font Awesome icons) render fine. I’m guessing that your workstation has it disabled hence why you couldn’t replicate. Would you be able to confirm?

    Why this is only happening to IE 11 and not Edge or any other browser for that matter is beyond me but appears to be the culprit nonetheless.

    Thanks again for your time.

    Steve

  • Yes, I can repro that. With this setting turned on, the fonts do not display.  Good find! This is more than likely the cause of the fonts not displaying as one might expect.

    I am glad that I was able to help you get the problem resolved. We look forward to more feedback from you in the future.

  • mam problem s internetem explorer,vyzaduje aktulizaci 11.494.10586.0

  • Fontawesome Wiki link above says to remove all occurrences of ?v=4.x.y from the @font-face property in the font-awesome.css".

    Which, if you are using LESS, means changing the /less/fa/path.less file.

  • Thanks Steve, Brad for finding a solution for this. As stated by Steve disabling the feature in registry from blocking font awesome is one of the solution for it to work. Wouldn’t it be a policy breach if I am blocking that and if IE 11.4.XX is enabling that by default ? Would like to know more about it before going for the solution.

    Thanks
    Kirit

You need to sign in to your Microsoft account to add a comment.

Sign in