Iframe reference bug

Fixed Issue #835911

Details

Created
Sep 15, 2014
Privacy
This issue is public.
Reports
Reported by 0 people

Sign in to watch or report this issue.

Steps to reproduce

URL:

Repro Steps:

==============

  1. Add an iframe element to a document.

  2. Refer it by directly calling its ID.

  3. Check the type of the result.

http://jsfiddle.net/saschanaz/5tuqpz81/](http://jsfiddle.net/saschanaz/5tuqpz81/)[http://jsfiddle.net/saschanaz/5tuqpz81/](http://jsfiddle.net/saschanaz/5tuqpz81/)

Expected Results:

==============

Any reference method should give expected HTML iframe element, not its content window object.

Actual Results:

==============

Dev Channel specific:

================

No

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Tony S.”

      Changed Assigned To from “Tony S.” to “Eugene V.”

      Changed Assigned To from “Eugene V.” to “IE F.”

      Changed Status to “Won’t fix”

      Changed Status from “Won’t fix” to “Fixed”

      Changed Status from “Fixed” to “Won’t fix”

      Changed Assigned To to “Travis L.”

      Changed Status from “Won’t fix”

      Changed Status to “Confirmed”

      Changed Assigned To from “Travis L.” to “Christian F.”

      Changed Steps to Reproduce

      Changed Assigned To from “Christian F.” to “IE F.”

      Changed Status from “Confirmed” to “Won’t fix”

      Changed Assigned To to “Bogdan B.”

      Changed Assigned To to “Matt R.”

      Changed Status from “Won’t fix”

      Changed Assigned To to “Travis L.”

      Changed Assigned To from “Travis L.” to “Eugene V.”

      Changed Status to “Fixed”

    You need to sign in to your Microsoft account to add a comment.

    Sign in