Owner document of a newly cloned xml text node is incorrect

Duplicate Issue #8474659 • See Issue #8475284

Details

Author
Oleksiy S.
Created
Aug 12, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
Duplicates
See progress on Bug #8475284
Found in build #
14.14393
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Steps to reproduce

  • run example (e.g. in IIS)
  • open index.html in EDGE browser
  • open console
  • Note: owner document is different for original and cloned node

Expected result
Owner document of a newly cloned xml text node is the same as for original text node

Actual result
Owner document of a newly cloned xml text node is incorrect

NOTE: can reproduce only with xml text nodes

From W3

What is the ownerDocument of a newly cloned node?
The clone will be owned by the same Document as the node it was cloned from.

Attachments

2 attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Ibrahim O.”

  • Thank you for your feedback. I see identical output on both object and HTML mode. Could you please send us your results for both normal and cloned text nodes. Please also let me know if I am missing something in here.

    All the best,
    The MS Edge Team

  • Microsoft Edge Team

    Changed Status to “Duplicate”

  • Hello,

    Thank you
    for the feedback. This issue appears to be a duplicate of

    https://developer.microsoft.com/en-us/microsoft-edge/platform/issues/8475284/

    Please visit the given link for more details and status updates.

     

    Best
    regards,

    The MS Edge
    Team

You need to sign in to your Microsoft account to add a comment.

Sign in