Sending value does not print some characters with a specific keyboard set

Fixed Issue #8513911

Details

Author
Ali N.
Created
Aug 17, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
2.10586
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Running the example found in many remote testing tutorials;

-Navigate to google.com via

{"url":"http://www.google.com/ncr"} 

command.

-Select the search field by

{"using":"css selector","value":"*[name=\"q\"]"}

-Then invoke the sendKeys command from a WebDriver client using;

{"value":["w", "e", "b", "d", "r", "i", "v", "e", "r"]};

Windows 10 Edge driver receives the message successfully. That is they are printed in the console like;

08:30:44.569 INFO - Executing: [send keys: 0 [[EdgeDriver: MicrosoftEdge on ANY (A2D87921-604C-4793-BEF8-BC44E5D512B7)] -> css selector: *[name="q"]], [w, e, b, d, r, i, v, e, r]])

But the “i” character is not entered into the text field (only webdrver) when the only keyboard in the system is "Turkish Q". Setting "English (US)" as the only keyboard does not result in the same behaviour, instead all characters are printed (as webdriver).

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Ibrahim O.”

      Changed Status to “Fixed”

    • Thank you for your feedback. I see the issue is repro on 10586 but appears to be this is no longer repro on 14393 which is the current public stable build. I will go ahead and close this bug as fixed for now. Please keep us posted if you see this issue persists on the latest build on your environment. We will be happy to assist you.

      All the best,
      The MS Edge Team 

    You need to sign in to your Microsoft account to add a comment.

    Sign in