Getting blank print preview only in edge browser for pdf print through java application

Not reproducible Issue #8530830

Details

Created
Aug 18, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
Reports
Reported by 2 people

Sign in to watch or report this issue.

Steps to reproduce

When content type from server is pdf then getting blank print preview in edge browser as in the attachment .
but in other browser print preview is getting perfectly fine .

Content type in response header is Content-Type: application/pdf

Do i need to set any extra header for edge browser to work this fine ?
If not what would be the solution ?

Thanks in advance

Attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Brad E.”

  • Would you be able to provide me with the sample of the PDF so that we can look into this, please?

  • We are generating pdf dynamically from back end . please find pdf in an attachment which we generate by other browser.

  • I’m using com.lowagie.text-2.1.7.jar for generating the pdf .My observation was that getting blank print preview in edge browser when i rendered pdf on html elements like object , emded ,iframe ,form coming from backend with headers ContentType : application/pdf and Content-Disposition:inline .please find my sample code(written in java) in this https://github.com/SravanChithari13/PdfPoc . Please run this code and open in edge .after rendering pdf on page use browser print option so that you get to know the problem

  • Sample code also provided till no reply from MSEdge .Is there no one from microsoft Edge to resolve this issue. Please help me . Sample code is here https://github.com/SravanChithari13/PdfPoc

  • I am still working on this item - if you require urgent assistance you need to open a support incident by visiting https://support.microsoft.com.

    I apologize for the delay in reviewing this feedback in detail.

  • It’s not urgent take your own time

  • Thank you for your patience, when I try and run this file from the command prompt I get an error returned that states:

    “No main manifest attribute, in com.lowagie.text-2.1.7.jar”

    Do you know if there is anything missing in the project? It seems that I need additional steps in order to make the jar file executable.

  • Just wanted to let you know that I am still working on this - I have not forgotten. I apologize for the delay.

  • Thanks for the instructions. I have this added into Eclipse and followed the directions but I am doing something incorrectly still. All of the files I added to my Eclipse Dynamic Web Project are showing up with red X icons.

    I will try a few more ways of creating the repro environment and update you if it fails or succeeds.

    I appreciate your patience, Java and Eclipse are not exactly areas I am familiar with.

  • Attached screenshot showing my Project Explorer for review.

  • Hi sorry for delay in replay ,
    You configured every thing fine but I’m not getting what went wrong. please attach your PdfPoc project as zip so, that i will correct it and send you back . also please share your marker tab of your eclipse as shown in attached screenshot so, that will figure out the problem

  • Microsoft Edge Team

    Changed Assigned To from “Brad E.” to “James M.”

  • I have the same issue, so if I can somehow assist you to find out the issue let me know!
    We also using flying-saucer-pdf:9.0.4 / iText:2.1.7 to render pdf’s

  • Hello,

    Thank you for providing this information about the issue. To help us repro this problem, please run dxdiag (Windows key + r and type dxdiag, enter, then click Save all Information) and attach the txt file. We really appreciate your assistance with this case.

    Best Wishes,
    The MS Edge Team

  • Microsoft Edge Team

    Changed Status to “Not reproducible”

You need to sign in to your Microsoft account to add a comment.

Sign in