Unable to load captions cross-domain with <track>

By design Issue #8832165

Details

Author
Bradley B.
Created
Sep 10, 2016
Privacy
This issue is public.
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Closed captions / subtitles via the <track> element on a <video> element do not work cross domain. We are using the <track> element. The files on the other origin return the proper Access-Control headers.

Some background on how other browsers handle it:
All other browsers on all platforms seem to display captions with no problems. This includes Mac/Safari, iOS/MobileSafari, Mac/PC/Chrome/Firefox…

To reproduce:

  1. Point your favorite browser at: https://util01.myodp.org/test/ie-cc-video-test.html
  2. Watch captions work everywhere except IE

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Ibrahim O.”

      Changed Status to “By design”

    • Hello,

       

      Thank you for providing your feedback on
      IE11.

       

      We are not accepting feedback on Internet
      Explorer through this portal any longer (unless security related). We welcome
      any feedback you have on Microsoft Edge using this website. This item will be
      closed as By Design since IE feature bugs are not being worked unless security
      related.

       

      All the best,

      The MS Edge Team 

    You need to sign in to your Microsoft account to add a comment.

    Sign in