Edge (long) freeze when copy the content of the url bar

Fixed, flighted Issue #8952679

Details

Author
josselin e.
Created
Sep 16, 2016
Privacy
This issue is public.
Reports
Reported by 5 people

Sign in to watch or report this issue.

Steps to reproduce

  • select the content of the url bar
  • ctrl+c or right clic -> copy

-> GUI freeze entierly

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Status to “Fixed, flighted”

    • Hello,

      This is a known issue that we are working on currently using  internal work item. Thank you for your feedback on MS Edge. Looking forward to hearing more from you in the future.

      I have closed this item as a duplicate of an item that was filed recently where I was told of the internal deliverable.

      All the best,
      The MS Edge Team

    • This has been a problem for over a year, and has kept me from using Edge that entire time. I tried switching to Edge today thinking surely this has been fixed by now (I could see other people had been reporting it over the past year), but it has not been fixed. WADR one really wonders how blatant a problem would have to be before MS would make it a priority, this being the shiny new browser and all.

      Here is someone complaining about the same problem in Aug 2015:

      http://answers.microsoft.com/en-us/windows/forum/apps_windows_10-msedge/edge-hangs-when-i-copy-the-url-in-the-address-bar/6416d140-902a-4239-89bc-bd5e2b4ad5ed

      And it was "me-too"d by 71 people. How about fixing this soon? (I wish I found it funny that when I tried to copy the above URL in Edge, Edge froze).

      I can repro this at will if you need an example.

    • incredibly annoying! you have to trick it into allowing you to grab a url and paste into outlook; i just had to use IE 11 for a session in an SAP software interface because none of the drop-down boxes work with edge

    • Hi there!

      Just wanted to let you know that I am also experiencing this, and have now switched to Chrome until this problem has a proper fix. Is there any ETA on a fix?

      Kind regards,
      Marcus

    • Please fix these two years old bug!

    • I found a fix for this on another site. The problem, at least for me, has to do with use of Remote Desktop. Unfortunately I cannot remember or find what I did to fix it! But you can at least verify that it is some sort of interaction with Remote Desktop that is causing the problem by closing any open RD sessions and then trying it.

      I feel like the fix had to do with going into the Local Resources setting and turning off sharing of the clipboard with the remote session, or some other configuration of the clipboard. On the other hand, I have that box checked now, I am running an RD session, and I can copy URLs. Maybe they have fixed this in Windows.

      OH – one more possibility is that it’s VNC viewers doing it. I see that I do have “Disable clipboard transfer” checked in my vnc viewer options, so possibly it was disabling that that fixed the problem. One or the other, I suspect.

      You can see people talking about VNC and this problem here:

      https://answers.microsoft.com/en-us/windows/forum/apps_windows_10-msedge/edge-hangs-when-i-copy-the-url-in-the-address-bar/6416d140-902a-4239-89bc-bd5e2b4ad5ed?page=5

    You need to sign in to your Microsoft account to add a comment.

    Sign in