Edge (long) freeze when copy the content of the url bar

External Issue #8952679


josselin e.
Sep 16, 2016
This issue is public.
Reported by 9 people

Sign in to watch or report this issue.

Steps to reproduce

  • select the content of the url bar
  • ctrl+c or right clic -> copy

-> GUI freeze entierly


0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Status to “External”

    • Hello,

      This is a known issue that we are working on currently using  internal work item. Thank you for your feedback on MS Edge. Looking forward to hearing more from you in the future.

      I have closed this item as a duplicate of an item that was filed recently where I was told of the internal deliverable.

      All the best,
      The MS Edge Team

    • This has been a problem for over a year, and has kept me from using Edge that entire time. I tried switching to Edge today thinking surely this has been fixed by now (I could see other people had been reporting it over the past year), but it has not been fixed. WADR one really wonders how blatant a problem would have to be before MS would make it a priority, this being the shiny new browser and all.

      Here is someone complaining about the same problem in Aug 2015:


      And it was "me-too"d by 71 people. How about fixing this soon? (I wish I found it funny that when I tried to copy the above URL in Edge, Edge froze).

      I can repro this at will if you need an example.

    • incredibly annoying! you have to trick it into allowing you to grab a url and paste into outlook; i just had to use IE 11 for a session in an SAP software interface because none of the drop-down boxes work with edge

    • Hi there!

      Just wanted to let you know that I am also experiencing this, and have now switched to Chrome until this problem has a proper fix. Is there any ETA on a fix?

      Kind regards,

    • Please fix these two years old bug!

    • I found a fix for this on another site. The problem, at least for me, has to do with use of Remote Desktop. Unfortunately I cannot remember or find what I did to fix it! But you can at least verify that it is some sort of interaction with Remote Desktop that is causing the problem by closing any open RD sessions and then trying it.

      I feel like the fix had to do with going into the Local Resources setting and turning off sharing of the clipboard with the remote session, or some other configuration of the clipboard. On the other hand, I have that box checked now, I am running an RD session, and I can copy URLs. Maybe they have fixed this in Windows.

      OH – one more possibility is that it’s VNC viewers doing it. I see that I do have “Disable clipboard transfer” checked in my vnc viewer options, so possibly it was disabling that that fixed the problem. One or the other, I suspect.

      You can see people talking about VNC and this problem here:


    • Hey Matt you are my hero. It was UltraVNC viewer which has been causing the issue. It is as you said, I disabled the clipboard transfer function in VNC and I was able to copy the URL out of Edge just normally. Just wondering why it causes Edge so much grief if the option is enabled.

    • As per Matt above, I can confirm this is related to RDS clipboard sharing. On my work PC I had RD Connection Manager open with one connection to a remote server and encountered this bug. The bug was repeatable and when I disconnected the RD session the bug immediately disappeared and I was able to copy Edge URLs without problem.

    • still not fixed. is this a joke?

    • August 2018 and this issue still appears to be current. On the one hand Microsoft is paying me to use Edge through the Rewards programme, and on the other they can’t be bothered to fix such a fundamental problem as this.

      Selecting Right-click > Copy or Ctrl + C hangs Edge for 5-20 seconds.

      By the way, I had to use Chrome to post this comment, as Edge just said that an Azure account could not be used to log in to this page but gave me no other options. Chrome allowed me to choose.

    • Yepp, still happens. Also, the is a bug when you “open Edge too fast” copy a URL in the url bar hit enter, it just does nothing, stuck, and you have to force close it and reopen. This is unbelievable.

    You need to sign in to your Microsoft account to add a comment.

    Sign in