HLS stalls after several hours

Won’t fix Issue #8967436

Details

Author
Andrew W.
Created
Sep 18, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Visit a continuos live HLS stream such as a CCTV camera.

The video will play fine for several hours (sometimes upto 24) then stall.

Sometimes stalls with a still frame, other times stalls with ‘Video cannot be decoded error’

Often refreshing will not work. Edge has to be shut down and re-opened to get the stream back.

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Brad E.”

      Changed Assigned To to “Venkat K.”

    • Further investigation has revealed it is a memory leak. When the video stalls Edge has used up all available RAM

    • Microsoft Edge Team

      Changed Assigned To from “Venkat K.” to “Stephen E.”

      Changed Assigned To from “Stephen E.” to “Matthew H.”

      Changed Status to “Confirmed”

    • Hi Andrew, could you confirm which version of the OS you are running, and which specific version of mfmediaengine.dll you have installed?

    • Microsoft Edge Team

      Changed Status from “Confirmed” to “In progress”

      Changed Status from “In progress” to “Confirmed”

      Changed Status from “Confirmed” to “In progress”

      Changed Status from “In progress” to “Won’t fix”

    You need to sign in to your Microsoft account to add a comment.

    Sign in