Unable to load captions cross-domain with <track>

Not reproducible Issue #8973058

Details

Author
Bradley B.
Created
Sep 19, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
  • Internet Explorer
Found in build #
25.10586
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

I opened an identical issue last week and was told that it was fixed in subsequent version of IE10/Edge, and the issues was closed. I’ve now upgraded to the versions below, and the problem persists. It’s clearly not fixed:
Microsoft Edge 25.10586.0.0
Microsoft EdgeHTML 13.10586
Microsoft Windows Version 1511 (OS Build 10586.589

Closed captions / subtitles via the <track> element on a <video> element do not work cross domain. We are using the <track> element. The files on the other origin return the proper Access-Control headers.

How other browsers handle it:
All other browsers on all platforms seem to display captions with no problems. This includes Mac/Safari, iOS/MobileSafari, Mac/PC/Chrome/Firefox…

To reproduce:
Point your favorite browser at: https://util01.myodp.org/test/ie-cc-video-test.html
Watch captions work everywhere except Edge (and IE).
This is a serious accessibility issue, captioning (some) web video is required by the FCC and this should work with html5 coding.

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Ibrahim O.”

    • You are missing anniversary update which is the current public stable version 1607. Please visit this link for more details https://support.microsoft.com/en-us/help/12387/windows-10-update-history I would like to also remind you that we’re not presently working on feature bugs in Internet Explorer outside of security-related issues. So I will keep this feedback status active until you verify the issue is not repro on the latest update. If you still have any issues please let us know we will be happy to assist you.

      All the best,
      The MS Edge Team

    • Microsoft Edge Team

      Changed Assigned To to “Venkat K.”

      Changed Assigned To from “Venkat K.” to “Steve B.”

      Changed Assigned To from “Steve B.” to “Venkat K.”

    • Could you please verify your repro link? We are having difficulties accessing your sample URL https://util01.myodp.org/test/ie-cc-video-test.html 

      Best regards,
      The MS Edge Team

    • Microsoft Edge Team

      Changed Assigned To from “Venkat K.” to “Brad E.”

      Changed Status to “Not reproducible”

    • I am able to see the video and the captions work perfectly fine.  It looks like you reported this in 10586 - Please retest in the latest stable public build of Win 10 14393 and let us know if you are still having issues with the captions.

      All the best,
      The MS Edge Team

    You need to sign in to your Microsoft account to add a comment.

    Sign in