Scrolling a large Bootstrap modal leaves 1px lines behind on boundaries on Edge / Windows 10

Issue #9011176 • Assigned to Matt R.

Details

Author
Avi
Created
Sep 21, 2016
Privacy
This issue is public.
Reports
Reported by 3 people

Sign in to watch or report this issue.

Steps to reproduce

Launch the demo on either Bootstrap v3 (http://getbootstrap.com/javascript/#modals) or Bootstrap v4 (http://v4-alpha.getbootstrap.com/components/modal/).
Make sure that the modal does not fit the current window (should be able to scroll).
When scrolling, note that it leaves behind 1px lines that bleed through to the background.
The lines are either vertical or horizontal and can also be “added” when resizing the browser.

It was noted here:
https://developer.microsoft.com/en-us/microsoft-edge/platform/issues/5986510/

And stated that it was not reproducible, but it is easily reproducible.

Attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Brad E.”

  • May I ask which build you were seeing this on, please? I just tested on 14393.187 and can not repro this. My guess so far is that you are running 10586 and have not installed the anniversary update which fixed the problem.

    Thank you for your feedback.

  • I can reproduce the issue (at least as far as the bottom horizontal line is concerned) in Microsoft Edge 39.14926.1000.0 / Microsoft EdgeHTML 14.14926 in 14926 prerelease Win 10 insider, on a Surface 3 (the issue is likely related to subpixel rendering and can only be reproduced on high-dpi display?)

    Refs: https://github.com/twbs/bootstrap/issues/20755

  • That would seem to make sense, actually. I swore that I saw the behavior on one screen, but not the other. I also tried a laptop on insider fast which was not repro … thinking that maybe it had been fixed.  Interesting.

  • Microsoft Edge Team

    Changed Assigned To to “Rick J.”

    Changed Assigned To from “Rick J.” to “Matt R.”

You need to sign in to your Microsoft account to add a comment.

Sign in