Microsoft WebDriver hangs on page load with authentication window

Not reproducible Issue #9122146

Details

Created
Sep 29, 2016
Privacy
This issue is public.
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

OS Edition: Windows 10 Enterprise
OS Build : 10586.589
Microsoft WebDriver version: Release 10586
selenium version : 3.0.0-beta3

  1. Open any site that requires authentication
  2. Authentication window is opened in browser
  3. WebDriver hangs for a few minutes or for a specified period and then returns ‘timeout’ response.

Server log ls:
D:>MicrosoftWebDriver.exe --host=localhost --port=17556 --verbose
Starting server…
Listening on http://localhost:17556/
Waiting for new request…

Received a request: POST http://localhost:17556/session
{"capabilities":{"desiredCapabilities":{"browserName":"MicrosoftEdge","version":"","platform":"WINDOWS"},"requiredCapabilities":null},"desiredCapabilities":{"browserName":"MicrosoftEdge","version":"","platform":"WINDOWS"},"requiredCapabilities":null}

Response: {"sessionId":"81D82634-FA6E-4A3A-A09C-D72DE6687EF2","status":0,"value":{"browserName":"MicrosoftEdge","browserVersion":"25.10586.0.0","platformName":"windows","platformVersion":"10","takesElementScreenshot":true,"takesScreenshot":true,"acceptSslCerts":true,"pageLoadStrategy":"normal"}}

Waiting for new request…

Received a request: POST http://localhost:17556/session/81D82634-FA6E-4A3A-A09C-D72DE6687EF2/url
{"url":"http://con-na-site1-plformdev-jnjctechstage1.jjconsumer.com"}

Response: {"sessionId":"81D82634-FA6E-4A3A-A09C-D72DE6687EF2","status":21,"value":{"message":"Timeout"}}

Waiting for new request…

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Ibrahim O.”

      Changed Status to “Not reproducible”

    • Thank you for your feedback. This issue appears to be not repro on the latest build which is tested on 14393 and will be closed as “Not repro” to reflect this. If you experience unexpected behaviors or the issue still persists please feel free to reactivate the issue.

      All the best,
      The MS Edge Team 

    • Hi,
      I’ve faced with same result on 14393
      Thanks

    You need to sign in to your Microsoft account to add a comment.

    Sign in