Clicked link is opened twice

Site Outreach Issue #9184238

Details

Author
Steven J.
Created
Oct 4, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
14.14393
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

The ‘_blank’ links on the following site open twice for me when ctrl-clicking:
http://en.community.dell.com/support-forums/laptop/f/3519/p/19660093/20945038/

  1. Ctrl-click on one of the links posted by joteroz3 on 3 Oct 2016 22:34.
  2. The clicked link opens twice, in two separate tabs.

Attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Ibrahim O.”

  • Thank you for your feedback. We are having difficulties reproducing this issue. Could you please confirm that issue repro despite rebooting the system and please also let us know your build number (winver.exe) It would also help us investigate the issue if you could provide your screen capture while the issue is happening.

    All the best,
    The MS Edge Team

  • I have since rebooted the system several times, and after checking just now, the problem with the specific link provided persists. This is an easy repro on my end, thus in case I can help you further by providing logs or anything similar, you can contact me personally (including a live screencast if need be).

    Additional details:
    Windows build number is: 14393.222
    Microsoft Edge 38.14393.0.0
    Microsoft EdgeHTML 14.14393
    LastPass and Adblock Plus plugins are installed
    The problem also occurs in an InPrivate window (thus no plugin issue I believe)

  • I tested this issue on 14393.321 which is still not able to repro and please see the attached screenshot (repro.gif) and keep me posted if I am missing something in here. I have also notice you say “posted by joteroz3 on 3 Oct 2016 22:34.” which I couldn’t see in the link you have provided. That’s why I have tested the links given on “Posted by joteroz3 on 3 Oct 2016 21:34”

    All the best,
    The MS Edge Team

  • The difference in search must be related to different time zones I presume; the ones you found are the ones I meant. Regardless, any link on that Dell forum written in the body of posts seems to behave like this, e.g., the FAQ links here: http://en.community.dell.com/support-forums/laptop/f/3517/t/19510764

    I do not see an attached screenshot, but I believe you that you can not reproduce. :) I just tried again (also on winver 14393.321 now) and it still occurs for me.

    In the meantime I also found out the search function is bugged. Opening the page (or refresh) without scrolling to the bottom first, and then searching for “joteroz” shows up no search results. Only when scrolling down, and then searching again the search result shows up (this is reproducible here). I will see whether this is reported elsewhere.

  • Regarding the ‘search’ issue. Apparently I was too quick to search, since it seemed the page was not loaded fully yet, and hence no search results showed up.

    That said, it did seem the page was loaded, but this makes this a UX issue which you do not handle here. The only indication the search results might be incomplete is the ‘no results’ text going from red to black.

  • In case the screenshot would make it more clear, this is what it looks like, right after ctrl-clicking the underlined link.

    I do not believe a video could make the reported issue clearer.

  • I have been testing this issue on multiple versions of Windows and still not able to repro the issue. To isolate the environment factor, could you please test this issue on a different environment or VM (https://developer.microsoft.com/en-us/microsoft-edge/tools/vms/) and let us know your results. Please also let us know if you experience the same issue with “Mouse wheel button click on the link” or “right click and open in new tab option” 

    Best regards,
    The MS Edge Team

  • Setting up a VM is too much of an effort for me right now, maybe later once I have more time. However, I quickly tested your suggestions, in addition to comparing trackpad vs. external mouse. I expected perhaps it is trackpad related since I’m having other peculiar issues with the drivers of this trackpad (slow scrolling in treeview listviews, http://en.community.dell.com/support-forums/laptop/f/3518/t/19987983). Trackpad and external mouse, however, behave the same before the observations mentioned below.

    Interesting new findings:

    • Right mouse click on the links does not open the context menu. Instead, it opens the link in a new tab.
    • This lead me to try a prolonged right mouse click. This does open the context menu upon releasing. Selecting open in new tab just opens the tab once.
    • After this I tried prolonged ctrl-left-mouse click, which opens the tab just once. However, a ‘quick’ (normal) ctrl-left mouse click as mentioned before, opens the tab twice.

    At this point it might also make sense rather than attempting a repro to simply look at the code where such funky behavior might arise?

  • We appreciate your effort and your assistance in the investigation, but we need to identify whether the issue is in our product or external before start triage the issue. It is likely that issue is related to environment and it is possible your right click functionality may have been altered. I also understand if it is too much to build VM but you can try to repro this in another computer (Preferably outside of your network) and see if that still gives you repro.  

    Best regards,
    The MS Edge Team

  • The issue might indeed be related to the environment, more specifically, something related to the Dell XPS 15 9550, perhaps some of the prepackaged drivers.

    I just got a full replacement of this system. I decided to revisit this issue to see whether it was related (thus an entire different, but same system), and out of the box this problem occurs (on a different network, my home network this time).

    Since I do not use Microsoft Edge anymore (because of countless other issues) I will not pursue this further. You might want to contact Dell directly if you want to address this, since this seems to be related to drivers they manage.

  • Microsoft Edge Team

    Changed Status to “Site Outreach”

  • Thank you for the update. We will close this bug as external and pursue the issue appropriately. Thanks again for your assistance in the investigation.

    All the best,
    The MS Edge Team

You need to sign in to your Microsoft account to add a comment.

Sign in