Support for HTML form attribute on input elements

External Issue #919605

Details

Created
Oct 6, 2014
Privacy
This issue is public.
Reports
Reported by 7 people

Sign in to watch or report this issue.

Steps to reproduce

URL:

Repro Steps:

http://www.impressivewebs.com/demo-files/html5-form-attribute/

Expected Results:

Form elements should be associated with the forms identified in the attribute.

Actual Results:

Dev Channel specific:

No

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Tony S.”

      Changed Assigned To to “Travis L.”

      Changed Status to “Confirmed”

      Changed Assigned To from “Travis L.” to “IE F.”

      Changed Status from “Confirmed” to “Won’t fix”

      Changed Status from “Won’t fix” to “External”

      Changed Steps to Reproduce

      Changed Steps to Reproduce

    • Please implement this NOW!

    • You have marked this issue as "Duplicate".
      Duplicate of what/which issue?

    • Is it really so difficult to implement… ?

    • I also don’t know what’s so difficult to implement this.
      Firefox had this in version 4 (!!!) already, Safari in (at least) 5.1.
      Even all mobile browser support this since ages.
      What’s really annyoing about this issue is that you can’t really workaround it.

      Please Microsoft fix this bug before the next Windows 10 release this summer!
      It shouldn’t be that difficult…

    • I want to pitch in here too. My web page worked fine on Chrome and Firefox, but I now realized that this made it unusable in its current form on Microsoft Edge. I either have to reimplement my site, or try to get users to switch to Chrome or Firefox. Please prioritize this!

    • You can solve this issue using javascript, see this thread http://stackoverflow.com/questions/20658402/internet-explorer-issue-with-html5-form-attribute-for-button-element
      Works perfectly for me, doesn’t support AJAX out of the box though.

    • Thank you Evjeiy, I will give it a go.

    • Can we have this in EdgeHTML 15 atleast. The support has been there for ages in other browsers.

    • Microsoft Edge Team

      Changed Steps to Reproduce

    • This isnt supported yet, like seriously?
      the first browser to do this was opera in 2009, most of the browsers did in in 2011, with the only exception being IE as always, and not even edge has this…
      This is not normal.

    You need to sign in to your Microsoft account to add a comment.

    Sign in