Edge crashes right after starting

Fixed, flighted Issue #9258944

Details

Author
Tolga A.
Created
Oct 8, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
Reports
Reported by 15 people

Sign in to watch or report this issue.

Steps to reproduce

Upgrade from1511 to 1607 was the reason.
Tried everything I found on internet.

Even a new created user has the same problem.

Faulting application name: MicrosoftEdge.exe, version: 11.0.14393.223, time stamp: 0x57f1e741
Faulting module name: iertutil.dll, version: 11.0.14393.206, time stamp: 0x57daca0b
Exception code: 0xc0000409
Fault offset: 0x0000000000064d18
Faulting process id: 0x314
Faulting application start time: 0x01d221417317b341
Faulting application path: C:\Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\MicrosoftEdge.exe
Faulting module path: C:\WINDOWS\SYSTEM32\iertutil.dll
Report Id: e7b9e888-67a1-445d-aa9f-72e33b59fcef
Faulting package full name: Microsoft.MicrosoftEdge_38.14393.0.0_neutral__8wekyb3d8bbwe
Faulting package-relative application ID: MicrosoftEdge

Attachments

0 attachments

    Comments and activity

    • Hello, I’m apparently facing the same issue. My PC is now up to date (08.10.2016 - Italian date) and every time I open Edge, after a few seconds and/or I have tried to digit a couple of characters, the browser crashes, and if you’re not quite fast to close it, it can even lead to auto rebooting my PC. The same thing obviously happen with all the apps which use Edge to browse the Internet.
      I think I’ve just tried every solution I’ve found in different forums and/or sites (primarily reset/reinstall Edge), but everything was useless. I believe that it is a very serious problem to resolve. Fortunately, other browsers like Chrome and Firefox work fine, and any other PC process/function seem to present no issue. Does anybody know anything to help me? Thanks in advance.

    • This is the same issue I’m facing except on the latest fast ring preview version from Oct 7, 2016
      Faulting application name: MicrosoftEdge.exe, version: 11.0.14942.1000, time stamp: 0x57f33e08
      Faulting module name: iertutil.dll, version: 11.0.14942.1000, time stamp: 0x57f33d2b
      Exception code: 0xc0000409
      Fault offset: 0x0000000000069b98
      Faulting process id: 0x1fb4
      Faulting application start time: 0x01d2216a95d8aa2b
      Faulting application path: C:\Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\MicrosoftEdge.exe
      Faulting module path: C:\WINDOWS\SYSTEM32\iertutil.dll
      Report Id: e68b4fca-7a54-49a2-a138-bd196eba9ecb
      Faulting package full name: Microsoft.MicrosoftEdge_39.14942.1000.0_neutral__8wekyb3d8bbwe
      Faulting package-relative application ID: MicrosoftEdge

    • I have the same problem. I have 3 Computers in my home currently running Windows 10 1607 Build 14393.222. On two of the machines, Edge fails to load. I get a blue screen with the Edge " E" and it reverts almost immediately to the Desktop screen.

      The third machine works fine!

      As far mas I can see, I did mothing to cause this problem. I haven’t added any software recently, or changed any settings etc. It just started happening.
      What Gives, and what can In do to fix it.

      Win 10 was pretty buggy before, however all the bugs seemed to clear with the 1607 upgrade. Till this started…

    • Microsoft Edge Team

      Changed Status to “Fixed, flighted”

    • Okay, we have two different people reporting the same problem on different builds. I’ll do my best. But in short, yes this is a known issue that started with 14941. Builds higher than this might be affected. If you are running anything lower than that - it might be something else. You might want to continue more troubleshooting.

      If you are on insider fast (14942.1000) as Todd is - please see this blog post:
      https://blogs.windows.com/windowsexperience/2016/10/07/announcing-windows-10-insider-preview-build-14942-for-pc/

      There is a powershell command you can run that might help.

      Thanks for the feedback, everyone. I hope this helps.

      All the best,
      The MS Edge Team

    • Hi Brad,
      Thanx for your effort and for your reply.
      On the other hand I’m an enterprise user and your answer does not meet my needs.
      As this was an issue after the in-place upgrade from 1511 to 1607, because of this risk now we can not dare update the existing win10 installation with older builds.
      A clean install is a solution but not the proper one - so much effort and time waste.
      The cumulative update today to build 14393.321 did also not help.

      Therefore switching the problem state to fixed was not proper.
      I hope your team can find a solution for it.

      Have all a wonderful day.

    • One more thing,

      After the in-place upgrade most of my win apps were affected like photos app.
      With some googling workaround I could fix them all but Edge.

      All the best,

    • As of the Creators Update, this is still an issue. Not sure why it has been marked as fixed when it isn’t.

    • I updated my enterprise W10 today and the issue still exists.

    • I am still having this issue with the latest update.

    • Also i’m getting exception 0xc0000409. Edge starts and closes after a short time. I am running Windows 10 Pro 1703, build 15063.413.
      i have tried many suggestions that can be found on the web, but not 1 is working to solve the issue.

    • Can also confirm that an in-place upgrade from 1607 to 1703 (Enterprise en-gb) is resulting in Edge becoming unusable and crashing with 0xc0000409 in nearly all test candidates.

      Have tried the following with no working result:-


      Get-ChildItem 'HKCU:\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppContainer\Storage\microsoft.microsoftedge_8wekyb3d8bbwe\Children' | foreach {Remove-Item $_.pspath -Recurse}
      

      Source- https://blogs.windows.com/windowsexperience/2016/10/07/announcing-windows-10-insider-preview-build-14942-for-pc/#LXd61R9Vzy1hlKlP.97


      rd /s /q %LOCALAPPDATA%\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe
      

      Run Powershell as administrator:

      Get-AppXPackage -AllUsers -Name Microsoft.MicrosoftEdge | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml” -Verbose}
      

      A thread over at TechNet forums echoes the problem, but is specifically related to 3rd party software interference:

      https://social.technet.microsoft.com/Forums/en-US/4af16a6b-00fb-452f-91dd-d384a4b0797a/microsoft-edge-crashes-on-windows-10-version-1703?forum=win10itprogeneral

      I very much doubt developers are watching issues marked as "Fixed", so it may be worth spinning this out to a new issue, for those of us who have tried all of the above.

    • Edge started working again after 1 of the latest cumulative updates, I think KB4034674 solved it.

    • I’ve tried August cumulative update (now at 15063.540 according to winver), and without re-running any of the previous commands, it still behaves the same.

      Can you confirm whether you ran any additional commands to remedy the profile / install (perhaps prior to patching)?

    • This happened on both Laptop (Win10 Home) and Desktop (Win10 PRO), both get the 0xC0000409 error on exit every time. Cannot use Edge. Both happened after CU update, and version to 15063.540. Unlike Jeroen P, the KB4034674 has NOT resolved the issue. I am going to disk-clone backup the desktop, and will try the Powershell re-install of Edge (seems to work for some folks).

    • I can confirm based on the thread I linked earlier, that our test candidates had 3rd party software installed which was negatively reacting with the Control Flow Guard (CFG) updates in Windows 10 / Edge introduced somewhere between 1607 and 1703.

      The vendor for the application has provided a workaround to stop it from attempting to hook into Edge the way it was trying to.

      In short: Look for any 3rd party security, firewall, monitoring, application or user management software you have installed as one or more items may be attempting to hook into the Edge processes causing them to crash.

      Given that the Control Flow Guard mechanism is there to protect Edge from outside interference, I’d imagine this is one of those “by design” things - though it being able to handle it more gracefully might result in less support calls & threads!

      More info on threat mitigations in Win 10: https://docs.microsoft.com/en-us/windows/threat-protection/overview-of-threat-mitigations-in-windows-10

    • Update on the Edge not working, and 0x409 exits : I used the renaming of the folder %LOCALAPPDATA%\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe to .OLD (rather than a removal, just in case) NOTE: I signed in as the REAL administrator account, to have the normal user profile unlocked, singed back in as the normal user, then executed the admin cmd with Powershell prompt, using the “add-appxpackage” command string as quoted above (I did not bother with the "-AllUsers" modifier, as there is ONLY one main account in my case (and EDGE does not work with the built-in Admin account, as designed). RESULT: now working OK on the WIN10 PRO on desktop, same command ran succesfully on Laptop (WIN10 Home), BUT this is STILL in a failing state. Both systems at 15063.540.

    • Another Update on the Edge not working, and 0x409 exits: I was looking at another forum, and noticed a post about a YOUTUBE video published by use rafaeljsc, that has a step-by-step guide, using similar re-install commands, but crucially, there is one extra step, that adds a missing HKCU Registry Key. As I had done the re-install stuff previously, I only did the last step, using an Admin CMD prompt:

      reg add “HKCU\Software\Microsoft\Internet Explorer\Spartan” /v RAC_LaunchFlags /t REG_DWORD /d 1 /f

      Just cut and paste that complete line into the CMD prompt, press Return/Enter, and in my case (as with many other folks), Edge springs back into life!

      What is odd, is that the Spartan key (Internal MS name for Edge), is NOT in that location on the working W10 Pro machine (seems to work OK without it once Edge was re-installed), but the W10 Home edition DID seem to need it!

      It seems that from what I have heard, Edge has different internal structures and Registry needs, between the main W10 editions. For instance the W10 Enterprise has Edge as a SytemAPP, WIN10 Pro I think is a UWP app, and Win10 Home is an (internal) feature limited Edge, and that edition does NOT have any GPO (Group Policy Object) functionality. This must mean that the Registry requirements differ vastly between those, so the occasional “missed” migration during a patch/upgrade/rollup is bound to happen from time to time. Hopefully MS will put a “fix-up” script inside a small KB, or even add a test and fix inside the upcoming Fall CU?

      Here is rafaeljsc’s video here:
      https://www.youtube.com/watch?v=Ho1G088NoHk

    • Since the last patch Tuesday we have the same issue with Edge on 1703. Edge starts but does nothing. The main windows is light grey. No URL or link works. After adding this key to users registry Egde starts to work again. 5 hours spent to fix this.

      reg add “HKCU\Software\Microsoft\Internet Explorer\Spartan” /v RAC_LaunchFlags /t REG_DWORD /d 1 /f

    • Once more: This registry key is undocumented. What does this key do? What means RAC? Why is the key located under Internet Explorer? Project Spartan after all this time? Can you explain a little to help me to understand what I do? Thanks!

    • @Dietmar H. : Possibly an old acronym for the in-built “RAC = Reliability Monitor Data Collection” - part of the Reliability Monitor build into the OS. Another possibility (but unlikely) is some function of the Retail Access Code retailer list, for demo functionality in PC retail stores.

      However, I think this stuff below is more likely:

      From a bit of “internal” sniffing around for files with RAC in them, I found an RACShare folder in Edge, and I spotted a few in Internet Explorer areas, possibly related to DRM certificates (RAC = Rights Account Certificate?)

    • Given the context earlier was all around security, I’m fairly sure RAC is an acronym for Restricted Application Container.

      Application Containers are discussed in the Edge Dev blog here: https://blogs.windows.com/msedgedev/2017/03/23/strengthening-microsoft-edge-sandbox/

      It notes that the Intranet zone runs in "RAC"; while not explicitly stating what the R stands for, given the context of zones within IE, it’s likely R stands for Restricted.

    • Chris M> - thanks for that useful input and the link. I did search for RAC_Launch before, but did not find that blog. Interesting info about the Sandboxing methods inside Edge Internals, App Containers, and the “tuned” (Or Restricted ones, hence the acronym RAC, as you say). I never thought about the connection to those, until you provided that link.

    • I’m also having issues with Edge after using a Task Sequence to deploy 1703 (OS Build 15063.608)

      I have a ticket opened but its going nowhere…

      https://developer.microsoft.com/en-us/microsoft-edge/platform/issues/14004473/

    • With this RAC_LaunchFlags setting we got it to work. However, after upgrade to 1709 Edge crashes again after a two seconds. This is a show stopper bug. We are not able to upgrade to Windows 10 1709.

    • After upgrading to Fall Creators Update I have the same problem with Edge. It starts but the window stays grey and after a few of seconds it closes itself. I’ve tried all this PowerShell-commands mentioned above, but without any success. The solution with the additional entry in the registry sounds quite promising. I will test this on my computers and report here.

    • Now, I have taken a closer look at the edge browser on two computers.
      Both computers are running Windows 10 Pro version 1709. On both machines there are no configuration files under Software Restriction Policies in Local Security Policies.
      On the first computer I was able to start the Edge Browser without any problems after the Fall Creators Update. There is only one local user account with administrative rights on this computer.
      On the second one, I was able to bring the Edge Browser back to life only by adding the Spartan subkey. On this computer is only an online Microsoft account with administrative rights.
      On both computers runs the Defender as the only antivirus program. The key difference are the user accounts: local or online. Is there a possible cause for the problem here?

    You need to sign in to your Microsoft account to add a comment.

    Sign in