Perf Profiler: Cannot generate report after stopping profiling, stuck at "Analyzing the collected data"

Fixed, flighted Issue #9373258

Details

Author
Alex L.
Created
Oct 16, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
  • Internet Explorer
Fixed in build #
15047
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Affected Branch:
RS_ONECORE_WEBPLAT_STAGE_DEV2

Affected Build:
15009.1000.170110-1804

Affected Product Language:
ENU

 

Repro steps:
 

  1. Open any website e.g: https://www.facebook.com/
  2. Launch F12, go to Performance tool
  1. Start and stop profiling
  1. Go to JavaScript call stack pane

 

Actual:

JavaScript call stacks window is blank after profiling.

 


 

With IE11’s "Profiler", I can collect JavaScript stack traces and timing against UI and Web Worker threads.

With Edge’s "Performance", all I get is a blank table without any data under “JavaScript call stacks” tab.

Please see other feedbacks in userfeedback VSO for feedbacks that are tracked by this work item.

Attachments

Comments and activity

  • This also affects IE11 on Win10.

    IE11 on Win7/8/8.1 works as before/expected.

  • Microsoft Edge Team

    Changed Assigned To to “Brad E.”

  • Thanks for the feedback on Edge. May I ask the version number of Edge that you are reporting this with? I tested this out on our public stable build (14393.321 of Win 10) and cannot repo this. Please see the attached screenshot for my JavaScript call stacks window.

  • This item of feedback will be closed out soon due to inactivity. If you are able to provide us with supplemental information to help us repro this please do so at your earliest convenience to avoid being closed for inactivity.

    All the best,
    The MS Edge Team

  • Microsoft Windows [Version 10.0.14393]

    See attached screen shots which give blank call stacks instead.

  • Is there any chance I could get a look at the page in the screenshot you provided?

    I am also curious if you can repro this on a web worker related page such as a simple jsfiddle I setup here:
    https://jsfiddle.net/s6w7ntqn/

    The JSFiddle itself does not seem to repro - but I am curious if I can get the same results on the domain that I see in the screenshot.

  • can it be adblock plus extension that block some of the java stack? in my case it seams to do a good job at hiding and blocking performance issue on most web page. when using f 12 performance js call stack some time it is blank or as very little on it.

  • I don’t have adblock plus installed.

  • The example you’ve provided at https://jsfiddle.net/s6w7ntqn/ works and shows "JavaScript call stacks" as expected.

    However, the site I was testing on still doesn’t work. This is the site that exposes https://developer.microsoft.com/en-us/microsoft-edge/platform/issues/9058600/ and in the previous tracker access was given to “Louis” for many months.

  • 9058600 is still open and being investigated. Is this being observed in Edge and IE?

  • Yes - both Edge and IE exhibits the same problem on Win10.

    IE on prior versions of Windows works as expected.

  • Microsoft Edge Team

    Changed Assigned To to “Leo L.”

    Changed Status

  • }This bug has marked as duplicate. Please follow the parent issue to get new updates.

  • Would you care to explain the connection between this bug, which is about F12 Developer Tools, to this one, which is about XHR not working properly?

  • Changed Status

  • No idea why the bug is marked duplicated, and I have an example where the Performance tab under F12 would show only call stacks on the main thread, i.e. none from the Worker threads.

    Profiler from previous versions of F12 show call stacks for all threads, main and workers.

  • Microsoft Edge Team

    Changed Assigned To to “Leo L.”

    Changed Assigned To from “Leo L.” to “Sarah D.”

  • I’m running into the kind of situation for both IE11 and Edge in win10 14971. The performance tab shows up, the recorder is available, I can click it and click stop after doing something on the page. The progress bar shows up that says "analyzing the collected data", but then I end up with basically a blank page (except it now says “start profiling…” The tools are useless now for web dev on those browsers under win10.

  • Microsoft Edge Team

    Changed Assigned To from “Sarah D.” to “Leo L.”

    Changed Steps to Reproduce

    Changed Title from “Edge F12 "Performance" does not work” to “Perf Profiler: Cannot generate report after stopping profiling, stuck at "Analyzing the collected data"”

    Changed Assigned To from “Leo L.” to “Fabio R.”

    Changed Status to “Confirmed”

    Changed Assigned To from “Fabio R.” to “Sandeep A.”

    Changed Status from “Confirmed” to “In code review”

    Changed Status from “In code review” to “In progress”

    Changed Status from “In progress” to “In code review”

    Changed Status from “In code review” to “Fixed, not yet flighted”

  • Sorry about the confusion and thanks for the feedback. We have a fix checked in at this time and should be released to the public with the next major update of Windows. It was originally marked as a duplicate because there was another work item in our database that we were using to track the problem. Sorry about that!

    All the best,
    The MS Edge Team

  • Microsoft Edge Team

    Changed Steps to Reproduce

    Changed Status from “Fixed, not yet flighted” to “Fixed, flighted”

You need to sign in to your Microsoft account to add a comment.

Sign in