Attaching F12 to extensions background page fails or breaks F12 on subsequent tabs

Fixed Issue #9529974

Details

Author
Maxim s.
Created
Oct 26, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
14.14393
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Steps:

  1. Open Developer Tools for background process of any extension / Debugger tab
  2. Open Developer Tools for any tab / Debugger tab

Expected: possibility to debug both scripts: extension background script and script of the tab.

Actual:

  • Sometimes DT of step 1 can’t connect to the process (in Console tab we have warning message).
  • Sometimes after success of step 1, step 2 open empty Debugger tab, without any warnings or errors.

Attachments

0 attachments

    Comments and activity

    • Microsoft Edge Team

      Changed Assigned To to “Brad E.”

      Changed Assigned To to “Leo L.”

      Changed Assigned To from “Leo L.” to “Paolo S.”

      Changed Assigned To from “Paolo S.” to “Jacob R.”

      Changed Status to “Confirmed”

      Changed Title from “Multiple developer tools did not support debugging” to “Attaching F12 to extensions background page fails or breaks F12 on subsequent tabs”

      Changed Status from “Confirmed”

      Changed Assigned To to “Mike J.”

      Changed Assigned To from “Mike J.” to “Lorne M.”

      Changed Status to “Confirmed”

      Changed Status from “Confirmed” to “Fixed”

    • Thanks for the feedback on our Developer Tools! We believe this issue is resolved as part of the Windows 10 Creators Update release. In the 14393 release (that you had installed), we were able to sporadically cause a script debugger attach error when following your repro steps. In the Windows 10 Creators Update release, the same issue could not be reproduced. As such we are marking this bug as fixed. If you encounter this problem again, please let us know.

    You need to sign in to your Microsoft account to add a comment.

    Sign in