history.back() problems

Confirmed Issue #9946679 • Assigned to Travis L.

Details

Author
Enrique C.
Created
Nov 24, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
  • Internet Explorer
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

When I use history.back() or window.history.go(-1) twice on EDGE browser, I go back and forward instead of going back twice.

Attachments

Comments and activity

  • In other browsers it works fine.

  • Microsoft Edge Team

    Changed Assigned To to “Brad E.”

  • I have not been able to repro this on my end using the latest public stable build - can you provide step by step instructions so I can be sure I am following the repro exactly as described?

    On my test I followed these steps:
    1.) Went to bing.com
    2.) Clicked on an article on the bottom of the page.
    3.) From there I clicked on an article
    4.) Opened the dev console and then input window.history.go(-1) and pressed enter
    5.) Entered the exact same command and hit enter again and the browser just goes back one more page

  • Sorry I didn’t give enough details before. The strange behaviour occurs when I use the History back() Method in my page this way:

    [back](#)
    

    If I remove ' href="#" ' it works fine, but I loose the hiperlink aspect. Please see the attached file I just added.
    Thank you.

  • Microsoft Edge Team

    Changed Assigned To to “Travis L.”

    Changed Status to “Confirmed”

You need to sign in to your Microsoft account to add a comment.

Sign in