Archive.org DOS emulation crashes Edge

Confirmed Issue #9952822 • Assigned to John-David D.

Details

Author
Ben G.
Created
Nov 25, 2016
Privacy
This issue is public.
Found in
  • Microsoft Edge
Found in build #
38.14393
Reports
Reported by 1 person

Sign in to watch or report this issue.

Steps to reproduce

Using Edge archive.org em-dosbox emulation implementation crashes the browser tab after it has downloaded and loaded its necessary files.

Steps

To replicate visit Software Library: MS-DOS Games on archive.org and select a title.

Example 1: https://archive.org/details/msdos_Donkey_Kong_1983
Example 2: https://archive.org/details/msdos_Alley_Cat_1984
Example 3: https://archive.org/details/msdos_Street_Fighter_II_1992

  • Click the HTML canvas to begin.
  • Wait for the download data to finish and the emulator to launch.
  • A DOSBox loading screen will start and then the tab will not respond and crash.

Video of the crash

These emulations have worked flawlessly in previous Edge editions.

Also other emulations on archive.org that rely on MESS/MAME seem to work fine.
Example https://archive.org/details/sg_Street_Fighter_II_Turbo_1993_Capcom_proto

Setup

Using Edge 38.14393.0.0 on Windows 10 64-bit 14393.447

Attachments

2 attachments

Comments and activity

  • Microsoft Edge Team

    Changed Assigned To to “Brad E.”

  • Hello,

    Thanks for your feedback on Edge. I tested this out on a VM running public stable (14393.447) and an actual laptop Insider Fast build (14971) and cannot repro this on either of the machines. My guess is that this might be related to hardware. Can you upload the output from a DXDiag file for us?

  • Hi Brad, I have attached the DxDaig and there is an Edge fault bucket at the end of the file.

    Recently I have flashed the motherboard BIOS and changed the graphics card in the machine.

  • Microsoft Edge Team

    Changed Assigned To to “Rico M.”

    Changed Assigned To from “Rico M.” to “Brad E.”

    Changed Status to “Confirmed”

  • I just tried this on Edge for Win10 Mobile in Continuum and it worked. It did seem like it locked up after the DOSBox logo appeared, but after 3-4 seconds, the game started.

    Edge 38.14393.576.0 on W10M 10.0.14393.693 (Lumia 950 XL).

  • Thanks for the additional input. Does this lock up / hang only happen while using Continuum?

  • No, it also hangs on the device directly. And to give some more info, it appears to actually freeze the browser, because it doesn’t draw if you scroll.

    That said, after waiting a few seconds, it does eventually boot the game and resume drawing.

    I would probably blame slow JavaScript. In OP’s case, they have an i5 6400 @ 2.7 GHz , which should perform a lot better than my Snapdragon 810 @ 2.0 GHz. Or at least, it feels that way, but looking at benchmarks, the Snapdragon 810 outperforms many Core i5 models (and I can’t find benchmarks for OP’s processor using a program that I can also run on my 950XL like AnTuTu). So maybe OP is experiencing slow JavaScript as well.

  • Microsoft Edge Team

    Changed Assigned To to “Rico M.”

    Changed Assigned To from “Rico M.” to “Lee H.”

    Changed Assigned To from “Lee H.” to “John-David D.”

You need to sign in to your Microsoft account to add a comment.

Sign in